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Foreword 

The 3Data Expert 16.0: Quick Start Guide document introduces the basic 3D 
model handling for Additive Manufacturing: triangle model repair and model 
splitting with 3Data Expert.  

There are two simple lessons, and it should not take more than 15 minutes to go 
through the examples. 

The first lesson fixes an erroneous STL model for 3D Printing using the Auto Repair 
process available with 3Data Expert 16.0 software. 

The second lesson describes methods to split and combine STL parts for 3D 
Printing. Large parts must be split, and pins must be added to be able to attach the 
manufactured parts correctly with 3Data Expert software.  

The pictures in this document can differ from the version you get. Most of the 
pictures have been grabbed with the classic theme, while the dark theme has been 
used for some of them. The theme can be changed from Edit > Preferences. 

User interface modes 

Compared to earlier versions of the software, the user interface has two modes: 

- Ribbon based interface for a straightforward AM workflow 
- Toolbar and menu based interface with a more complete set of commands 

(and similar to earlier versions) 

In these tutorials, the traditional toolbar and menu based interface is used. 
Because now, after installation, the default user interface is the ribbons, you may 
want to change the interface to menus and toolbars during your tutorial sessions. 
To switch between the modes change the setting in the Edit Preferences User 
Interface tab. To enter the user interface choice: 

- From ribbon mode to menus and toolbars, select the Settings tab and click 
Edit Preferences 

 
- From menus and toolbars to ribbon mode, select Preferences in the Edit 

menu: 
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Then choose the desired user interface mode: 

 

 

3Data Expert modules 

DeskArtes 3Data Expert consists of several modules targeted from home and DIY 
use to education and professional Additive Manufacturing. Each module has 
different menu and toolbar set, and which set you see depends on your license. 
With an evaluation license the Base menu and toolbar set is shown. 

− 3Data Expert Free is an entry level tool targeted for viewing, verifying, 
repairing, dimensioning, and communicating 3D geometry information. It 
allows you to input triangle models, create consistent topology, check 
errors, orient normal vectors, repair gaps and self-intersections, edit 
triangles and output STL data for 3D printing, without any cost. In the 
tutorials, when information relevant to the Free module is handled, it is 
marked with  

− AM Expert module (an option to Free and Base) provides automatic AM 
process selection based on part requirements (material, size, accuracy, 
tensile strength, and post processing). The AM Expert database currently 
contains data for 129 professional AM systems, and it is regularly updated. 

− 3Data Expert Dimensions is a simple, economical, and user-friendly tool for 
STL repair and 3D model splitting for machines with a smaller build area. 
The tools include Repair, Splitting and Connect with Pins or Lap Joint. 
Information relevant to Dimensions will be marked with . 

− 3Data Expert Lite includes all standard 3D model preparation tools for 3D 
Printing and Additive Manufacturing. Available tools include geometry 
generation, Boolean and 3D markup commands, Offset, Hollowing, 
Coloring and Texturing, Solidify (aka “shrink wrap”), as well as Slicing and 
Tool compensation. Optional 3D Nesting makes 3Data Expert Lite a perfect 
3D data preparation tool for powder-based AM systems. Information related 
to Lite will be marked with . 

− 3Data Expert Base is a professional tool for preparing 3D models for 
Additive Manufacturing and Simulation applications. There are several 
commands for manipulation of both 3D surface models and 3D faceted 
models. These commands include Surface triangulation, STL verification 
and repair, STL Offsetting, Splitting, Connecting, Decimation, Smoothing, 
Solidify, Boolean, Part subdivision, 3D Nesting, Z Compensation, Slicing 
and Tool Compensation as well as STL Coloring and Texturing. Supports 
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can be generated for DLP, metal and stereolithography processes. Special 
Sand Support command creates supporting plates for delicate sand parts 
with a push of a button. Information relevant to Base is marked with . 
However, most of the tutorial contents are applicable with Base. 

− 3Data Expert Color ( ) contains a subset of 3Data Expert Base, 
especially meant for handling color models. A variety of color and texture 
specific input formats are handled: VRML, ZPR, 3DS, OBJ, PLY. 3Data 
Expert Color has previously been labeled as DeskArtes 3DEdit Pro. 

3Data Expert tutorials 

The full tutorial set for 3Data Expert contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu:  

⚫ 3Data Expert 16.0: Quick Start Guide gives a short introduction to model 
repair and splitting for 3D Printing with 3Data Expert ,  and 
modules. Estimated completion time 15 minutes. 

⚫ 3Data Expert 16.0: Tutorial 1 – Working with 3D Models introduces basic 
viewing, measuring, automatic repair, split, connect, hollow, offset, 3D Text, 
Boolean, cut, reduce, 3D nesting, surface triangulation and other model 
manipulation functions available for STL files. Applies to all 3Data Expert 
modules. Estimated completion time is 3 hours.  

⚫ 3Data Expert 16.0: Tutorial 2 – Working with Colors introduces basic 
automatic repair and coloring for 3D Color Printer users. For , and 

. Estimated completion time is 1 hour.  

⚫ 3Data Expert 16.0: Tutorial 3 – Separating Shells describes the use of Shell 
Separation commands in 3Data Expert. These commands enable 
separating a part into several shells for different material (shore value) or 
color definitions in a single part. For  only. Estimated completion time is 
30 minutes.  

⚫ 3Data Expert 16.0: Tutorial 4 – Generating Supports for AM explains the 
use of the Generic Supports command and Sand Supports command. The 
support generator can be used to generate supports for DLP, metal, 
stereolithography and sand-based processes. Adding extra connectors to 
prevent parts from warping and bending during the build is explained. Also, 
slicing, slice preview and slice filling is demonstrated. Estimated completion 
time 1 hour.  

⚫ 3Data Expert 16.0: STL and VRML repair examples document includes 
more advanced model repair operations with 3Data Expert. Applies to  
and mostly to ,  and . Estimated completion time 2 hours.  

The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its subfolders (GeomFiles, Tutorial 1, Tutorial 2, etc.) in 
the 3Data Expert installation directory.  



3Data Expert 16.0: Quick Start Guide  

 Page 7 

Lesson 1 – Basic Workflow  

Welcome to 3Data Expert 16.0 tutorial Lesson 1. 3Data Expert 16.0 is a 64-bit 
implementation allowing you to handle huge models for Additive Manufacturing 
(AM) and Simulation applications. But let's start with simpler models.  

This lesson shows you how to fix an erroneous STL model for AM using the 
automatic tools with 3Data Expert 16.0. Before starting the lessons, please make 
sure you have received and installed the software evaluation license from 
DeskArtes. If you do not have a license yet, it is very simple to request an 
evaluation license. First start the program from the desktop icon: 

 

Then go to the Program licenses dialog through Help > Licenses command. There 
you can find the Request evaluation license on-line button.  

 

Press it and it will open the DeskArtes license request page on your favorite web 
browser. Fill in the required fields and press Submit evaluation request button to 
send the license request to DeskArtes. 
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You will receive a 15-day evaluation license within 24 hours.  

When the license arrives, press Install license code button in the Program licenses 
dialog and Copy/Paste the license string into the input field that appears: 

 

You can choose between three locations for the license. The first one, 
“ProgramData” folder, is usually the best one because it allows other users to 
access the license, too. 

Then press OK as requested to accept the license. Finally, restart the software. 
Now you are ready to go ahead with the lessons! 
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Basic workflow for STL files 

The default settings of 3Data Expert allow a straightforward workflow for 
processing STL files which either are already correct or easily repairable. The 
workflow consists of four steps: 

1. Model file input. 
2. Model positioning. 
3. Preparation for AM: support structures, slicing. 
4. Output as STL file, CLI slices or slice bitmaps. 

If you have previously worked with 3Data Expert, you will see that the process is 
significantly simplified, with more automation by default. However, you can still do 
all the operations possibly required with more difficult models. Some of these 
operations are explained later in this document with hands-on examples. 

Let’s first look at the preferences (Edit > Preferences and its General section). The 
units query dialog and Operation Mode dialog are turned off by default, setting the 
default unit as millimeters and automatic model verification or repair turned on. 
You can, of course, turn them on if input models require more interaction during 
input and verification. 

 

We’ll first open file dino-scaled.stl in the Tutorials/GeomFiles folder, using the 
File > Open command. Make sure that Files of type is set to STL or All files to see 
the file in the Windows file open dialog. 
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As we see from the object properties area and the coordinate axes drawing, the 
model is clearly outside the GenericDLP workspace loaded with the default Print 
Configuration: 

 

We will therefore use the Move to Platform Center command to move the dinosaur 
model to center of the workspace and 5 mm above the platform (the default bottom 
offset of the GenericDLP Print Configuration): 

    

Because the model is now correct and properly positioned inside the workspace, 
we can proceed and create the support structures necessary for its AM printing. 
The procedure is covered in detail in another tutorial, and here we will show the 
simplest step in three pictures: 

 

The left picture shows the state when support structure generation has been 
started: local minima points are highlighted. Step 1 is to click the Create button, 
which creates support geometry based on the Print Configuration parameters, as 
well as model geometry and topology. In step 2, the automatic supports are 
accepted with the OK button and appended to the model tree. 
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You can next output the model and the supports, either in one STL file or as 
separate STL files, depending on your process requirements. You can also slice 
the model and save the slices as a CLI file or as bitmaps, again depending on what 
your AM system wants to receive. In this picture two views of the slicing are shown, 
all 326 slices in the background image and 61 bottom slices in the inset image. 

 

If the slices are exported as bitmaps, below we see part of the ZIP package 
contents (left) and bitmaps of four different slice levels (bottom slice with supports 
only, two middle levels with both model and supports visible and, last, a level near 
the dinosaur top): 

 

 

During the workflow, you can save the intermediate results as a DeskArtes 
proprietary .3de format, or its compressed .3dez version. In addition, mainly for 
iterative work with support structures, you can use the .3de_project file format. 
These formats maintain, among other features, the topology of the entire model. 

In the following chapters will well go more deeply inside the repair process. The 
knowledge can be useful even if the basic workflow covers most of your AM 
production needs. 

  



3Data Expert 16.0: Quick Start Guide  

 Page 12 

Lesson 2: Fully automatic STL fixing 

After the quick introduction to the simple workflow, let’s now study the most AM -
related repair and modification procedures. During this lesson you will also learn 
how the user interface of 3Data Expert works. 

Auto Repair process for STL files 

When inputting a triangulated model into 3Data Expert, an automatic analysis and 
repair process is started. In normal everyday use you can verify and correct most 
of the models using the Auto Repair process. We will now show how the Auto 
Repair process works. Certain interactions in the following (like units and operation 
mode selection) are automatic by default, but they are shown here to emphasize 
what you can do when the automatic procedure doesn’t do what you need. 

If you choose to continue with the default automation, you can skip the rest of this 
chapter and continue to the Workspace chapter. 

First open the dino-connected.stl file in the Tutorials/GeomFiles directory with 
the File > Open command. Make sure the Files of type is STL: 

 

Press Open to bring the model into the software. If you often handle models with 
different units (like millimeters and inches), you can switch on the unit selection 
dialog display setting in the preferences (Show units dialog when opening a file). 
If you see the unit selection dialog now, accept the proposed units Millimeters (with 
automation, millimeters are automatically assumed): 
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Press OK to continue and you will be prompted for the Operation Mode. 3Data 
Expert has six main operation modes: Fix, Modify, Position, Print, Color and View. 
Note: The contents of the Operation Mode window depend on the 3Data Expert 
module you are running. The different modes are used for specific tasks: 

⚫ Fix takes you to automatic model verification and repair and contains 
shortcuts to the main tools used for repair work.  

⚫ Modify lets you change the model geometry with features which are 
necessary or useful for production. 

⚫ Position contains tools which help you optimize the positioning of 
components on the printing platform. 

⚫ Print shows tools for preparing a repaired and positioned model for your AM 
printer, such as creating support structures and slicing.  

⚫ Color displays the tools for painting and texturing. These tools check the 
model for errors and set it to “what you see is what you get” display color 
mode.  

⚫ View minimizes the Operation Mode window and allows you to examine the 
model and then return to Operation Mode selection when clicking the 
minimized window again.  

 

 

The normal way to begin repairing a model is to start with the Fix mode. To start 
fixing press the Fix button in the Operation Mode dialog now. 3Data Expert will 
begin automatic model verification (Fix Model > Verify Shells command). A 
progress bar appears. When the analysis is ready, the Auto Repair dialog with 
Model status message is displayed: 
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The model is verified for errors and divided into separate shells during verification. 
In this case we get only one shell (1. dino-connected (Verified)), which also 
contains errors. The display shows red Gap curves through the surfaces. You can 
use different viewing commands when the Auto Repair dialog is visible (see 
below). Gaps are an error type you must fix during the repair process of dino-
connected.stl.  

The shell has errors (i.e. gaps), which is indicated by the red icon  in the Model 

Tree (correct shells would have green icons or, sometimes,  if the model 
contains only unharmful errors).  

On the right-hand side of the graphics area, 
you will see the Tools Window. The Fix Tab 
on the Tools Window provides shortcuts to 
the commands available for repair, like 
Repair Shells and Fill Gaps commands. The 
Help text window at the lower part of the 
Tools Window also contains information for 
required repair actions. Command icons are 
greyed out while in Auto Repair process. We 
will learn more about these commands in the 
Tutorials, now we will follow the Auto Repair 
process.   

 

Auto Repair is the best path to follow when repairing everyday models. Auto Repair 
will attempt to fix all shells with errors in the Model Tree. Especially when you only 
have one shell, like now, you should always try Auto Repair first. The parameters 
for Auto Repair are automatically set based on the model properties. Normal 
Repair is set because there is only one shell to repair, and Fill gaps in all shells is 
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set because there are no open/flat shells in the result (which would require offset 
or some other fixing methods available in 3Data Expert).  

Press the Yes button to initiate Auto Repair now. 

When Auto Repair is started each shell is run through the automatic repair 
command (Fix Model > Repair Shells command) using automatically calculated 
parameters. For each shell, a progress bar shows the progress of the repair. After 
the Auto Repair process the following Model Status message is displayed: 

 

Press OK to close the window.  

During Auto Repair, 3Data Expert fills all gaps and removes non-manifold triangles 
(overlapping triangles, multi-edge triangles, duplicate triangles, triangles having 
less than three neighbors, etc.) from the model. Overlapping and duplicate 
surfaces are analyzed and connected in the optimal way. If you want to learn more 
about triangle errors, please see the “Triangle errors” page in the Online Help 
chapter “Handling Faceted Files”.  

The dino-connected.stl model only has simple errors, like inverted triangles and 
gaps, which are all fully repaired during the Auto Repair process. The model is 
now correct and can be 3D printed (or taken into simulation software), as indicated 
by the status information in the Help text window below the Fix Model Tab on the 
right-hand side of the screen.  

 

Workspace 

When you open a file in 3Data Expert, a workspace is automatically added to the 
model and shown in the graphics window. In the case of the dino-connected.stl 
model, you get the following warning 
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.  

This happens because the dino model does not fit into the workspace in the y-
direction. 

 

Note that the coordinate axes indicator (at bottom-left in the dark theme) of the 
view shows as red the directions in which the model extends outside the 
workspace. 

 
We do not concentrate on the workspace now. We will later teach how to split the 
model to be able to manufacture it with the printer specified in the Print 
Configuration. Now we will just turn off workspace display with View > Show 

Platform command (or the  icon).  
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Automatic positioning into workspace 

By default, 3Data Expert just loads the geometry where it was in the input file. You 
can turn on automatic positioning if it better suits your workflow, in Edit > 
Preferences: 

 

When the checkbox Position model to platform XY center is turned on, models are 
automatically positioned on the platform, around its center. Sometimes, mainly 
when importing models from other formats than STL, automatic positioning can 
move model parts in an undesired manner: 

 

In this case you can simply “undo” automatic positioning to restore the model into 
its original position using command Edit > Undo Input: 
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Basic viewing commands 

You have just fixed your first model with 3Data Expert software. Now try the 
following commands to become familiar with viewing operations.  

Note that the commands below do not alter the model’s true 3D coordinates. They 
only alter the eye-point location:  

⚫ Rotate the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. MMB rotation is always available. Left mouse button 
(LMB) rotation is available most of the time except when working with 
painting, texturing, curve editing, and transformations, However, LMB is 
mostly used for selecting objects, as shown later. 
In case you do not have 3-button mouse, you can also use key combination 
Ctrl + Shift + LMB or Ctrl + Shift + mouse wheel (MoW). 

⚫ Rotate the model around a selected surface point by pressing the right 
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of 
the model when the RMB is pressed. When you keep the Alt key down 
before and during the RMB rotation, the nearest triangle corner is chosen 
as the rotation fix point. 

⚫ Pan the model by dragging with the Shift + MMB (or LMB most of the time) 
(Shift + MMB means pressing the Shift key and dragging with the mouse). 
For panning, you can also use Shift + MoW. 

⚫ Pan with rubberband by dragging with Shift + RMB. 

⚫ Zoom in/out by rotating the MoW. 

⚫ Zoom in/out with Ctrl + MMB (or Ctrl + LMB).  

⚫ Zoom to box with Ctrl + RMB.  

⚫ Hide all by pressing the       icon with LMB (or F5) 

⚫ Show all by pressing the        icon with LMB (or F6) 

⚫ Fit the model by pressing the       icon with LMB (or F7). 

 

The main viewing command icons reside in the Viewing Toolbar: 

 

Try them out now. The tooltips provide a short description of each icon (let the 
cursor remain on top of the icon for a short while to see the tooltip): 
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Also, the Viewing Planes toolbar allows you to select any projection direction as 
the viewing direction with LMB: 

 

 

You can show the green selection box around the selected object by pressing the 
Show Bounding box icon in the Viewing Toolbar: 

 

Try also Clipping functionality through 
the Clipping Tab to look inside the model. 

The Clipping Tab is opened with the    
icon. The clipped area can be displayed 
with different ways, like as wireframe or 
transparent.  

Clipping also enables to extract real time 
slice information of the model. Real time 
slices can be used to visually check the 
model quality or be copied to the Model 
Tree for internal model dimensioning with 
the Edit > Save Clip curves command.  

  

 

Selecting objects 

On the left-hand side of the 3Data Expert software window, you can see the 
Model Tree tab. 
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This tab tells you the current contents of the 
program database. With this example you 
can see one shell (aka node, group) 1. dino-
connected (Repaired). The node 1. includes 
the correct dino model, as indicated by the 
green  icon with the shell. The (Repaired) 
text describes the last command run on the 
surfaces, which in this case is repair.  

 

Above the model tree a row of object-
dependent buttons is shown. Three buttons 
are always displayed:  for collapsing the 
tree,  for showing or hiding the selected 

object, and  for fitting the selected object in 
the graphics window. 

 

 

If you click the +-icon at the shell 1. it will open 
and display the separate triangle surfaces the 
dino model is made of. During the repair 
process the model is subdivided into separate 
surfaces along sharp edges. Triangle surfaces 

are indicated by a yellow triangle icon and 
the last operation name, i.e., 1. Repaired for 
the first and largest area triangle surface in the 
model and so forth.   

Below the model tree, properties of the 
selected object are displayed. The 
properties shown vary according to 
object type. 

 

 

You can select objects at different levels either directly from the Model Tree with 
LMB click or graphically from the display area. For example, the fourth surface (4. 
Repaired) selected from the Model Tree corresponds to the sole of the front right 
leg of the dino model. This is indicated with some highlighting and a green 
bounding box around the selected surface in the display area: 



3Data Expert 16.0: Quick Start Guide  

 Page 21 

 

 

Different objects can also be selected graphically from the display area with LMB. 
On the right-hand side of the screen, you can see the Tools Window which includes 
the Selection mode icons.  

 

The Selection mode icons allow you to set 
the graphical selection level to All, Shell, 
Surface, or Gaps. The default mode, Shell 
level, is shown “underlined” with a red band, 
as shown in the image on the right. If you 
click on the dino model on the screen with 
the LMB, shell 1. dino-connected (Repaired) 
will be selected in the Model Tree.  

Generally, the Tools Window contains handy 
shortcuts to available commands in the 
selected Operation Mode. The Help text 
window shows useful advice for the selected 
object or for the command in progress.  

 

 

 

With DeskArtes 3Data Expert software you should normally select an object and 
then run the desired command on it, as seen in the next lesson.  
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Lesson 2 - Splitting and Combining STL 

One of the most common tasks with 3D Printing is to split a large model into smaller 
pieces to fit into the build area. This lesson shows you how to split large STL 
models for Additive Manufacturing. Sometimes building a very tall part is more 
expensive than building two shorter parts simultaneously. Also, the building area 
may not be large enough for a very big part. Correct joining of the split parts is 
ensured by adding guiding pins to the models. 

This lesson does not apply to the Free module.  

Splitting the dino model 

Start by inputting the DeskArtes geometry file DinoOk.3de in the 
Tutorials/GeomFiles directory. Give the File > Open command. During the input 
you are prompted if the previous dino-connected model should be stored into .3de 
(DeskArtes proprietary format) file. You should press No when prompted and 
continue to the file Open window. Set the correct File of type (.3de) and select the 
DinoOk.3de file for input.  

 

The file includes a correct triangulation of the familiar dino model. 
You should accept the proposed units and go directly to the Modify 
mode by pressing the Modify button (shown on the right) in the 
Operation Mode Window.  

You should see the following dino model: 
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with the Modify Tab shown on the right-hand side of the screen. 

 

The Modify Tab gives shortcuts to the mostly 
used model modification commands, like split, 
connect, add lap joint, hollow, offset, drain hole 
and 3D text. The Help Text provides context 
sensitive help to the commands.  

 

 

Select node 1. DinoOk (Repaired) by clicking it with the LMB in the Model Tree. 
Before the splitting, we must take a correct view to the model because the splitting 
plane is generated by extruding a user-defined split polygon away from the viewer. 
Normally, with 3D Printing the correct way is to split the model perpendicular to the 
z-axis to make the part lower. Thus, take a view from the x-axis direction with 

 + LMB (or View > Ortho View > Front (+X)). 
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The splitting is started with command Modify Faceted > Split or with the 
command shortcut in the Modify tab: 

 

The system prompts you to take the correct view direction if no yet set:  

 

When the view is correct you can press Continue or Cancel to quit. You may hide 
this window permanently if necessary, by ticking the “Don't show this window in 
the future”.  

The Split STL parameter dialog appears. The system asks you if you wish to use 
a Polyline (linear), Curved split line, or Coordinate value. We will select Polyline 
for this exercise:  
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After pressing OK, the system goes into the curve edit mode where you can define 
the shape of the splitting surface. Press OK now to start the curve edit mode. 

In the curve edit mode you can draw the shape for the splitting surface. Draw a 
horizontal line by giving two points with the LMB clearly outside of the dino 
model as seen in the image below:  

 

The curve editing is finished by pressing the RMB (or ESC key to cancel). When 
RMB is pressed the model is split along the plane defined with the polyline. After 
a while the result is available in the Model Tree. You can select the upper part 
with LMB click on the graphics area or selecting the correct shell from the Model 
Tree.  

 

 

The two halves are named with prefixes a- and b- to distinguish between the shells 
above the split line and below the split line. 
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Creating the pins 

We would now be able to position the separate parts of the model and store them 
into STL files for 3D Printing. However, precise joining of the printed components 
would be difficult or impossible. To be able to position the parts accurately we shall 
add pins in the models to connect them accurately together after finishing the build. 

We will first locate the necessary primitives (sphere, cone, cylinder) which will 
connect the two parts together. For that purpose, we will need a nice view to point 
the pins on the model. Here we are also using the shaded+wireframe view mode 

available with the     icon.  

Let's start. First rotate the model, erase the screen and display the lower part 
of the dino. Zoom in to the front end of the model to be able to accurately position 
the connectors with the next command. 

 

 

The pins are now created with the Modify Faceted > Connect command or 
using the Modify Tab shortcut 

 

 

After the command is given, it is possible to give the shape and the size for the pin 
to be created. The software computes default values based on the model bounding 
box when use default (1/10 of max ext) is set. Now set Diameter and Length both 
to 10.0, as seen below:  
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The pins are positioned with LMB clicks on the display area on top of the dino 
model. Give two locations, the positions for the red conical pin location indicators 
should look like the image below when set. Note that you can use the MMB zoom 
and MMB rotation to change the viewpoint when locating the connectors.  

If a connector location is not correct you can remove it by clicking on the red 
indicator cone again. Then reposition with another LMB click on the correct 
location.  

 
 
When ready Press OK to generate the connectors. After a while you will see the 

connectors added to the selected shell (in shaded mode again with the  icon):  
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Corresponding holes are automatically created to the complementary component 
shell. 

Transferring the result for 3D Printing 

You can save both components into the same STL file by selecting the Model Tree 
root All. Anyhow, you usually want to build and position the parts separately in the 
3D Printer. For that, select each shell separately and output it to a proper STL file 
with File > Save As command.   

If you wish to save the two parts into one file, you should move the shells apart 
from each other with the Transform or Print Preparation > Move to Platform menu 
commands prior to outputting the model for 3D Printing. To output one file, select 
the Model Tree root All before the File > Save As command.  

 

Further Reading  

This Quick Start Guide has given you the skills to 

• Verify and repair models with moderate or few errors for 3D Printing. 

• Model splitting for building with systems having smaller build areas than the 
part size. 

• Data transfer of the repaired model to further processes has also been 
explained.  

Each 3Data Expert software comes with a set of useful tutorials available through 
Help > Tutorial Documents menu.  

More information and other STL manipulation tools can be found in the Handling 
Faceted Files section of the application Help pages. These pages contain 
information on model verifying, repairing, splitting, offsetting and hollowing for 
Additive Manufacturing. 


