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Chapter 1 – Foreword 

DeskArtes 3Data Expert software is a general AM tools, covering everything from 
CAD viewing to STL/VRML data transfer for 3D printing, Additive Manufacturing, 
and simulation software packages.  

This document, 3Data Expert 16.0: STL and VRML repair examples, describes the 
use of the latest improvements done for the faceted model repair with 3Data 
Expert. The use of the commands will be shown through several examples and 
these commands for faceted model repair (in particular) are covered in the 
document: 

- Fix Model > Verify Shells and Repair Shells commands for automatic model 
verify and repair, 

- Fix Model > Edit Triangles command for manual model editing, 

- Modify Faceted > Boolean and Multiple Join commands for part combination 
and cutting, 

- Create Geometry > Extrude Surface to add material on surfaces,  

- STL, VRML and ZPR output for 3D printers, 

- and several other supporting commands. 

The examples contain both STL and VRML models. The techniques shown will 
apply to any STL, VRML and ZPR model, because the file formats are all used for 
defining faceted (triangulated) models. The repairing of STL, VRML and ZPR 
models is identical, the only difference being the additional color and texture 
handling available for VRML and ZPR models. With 3Data Expert, textures and 
colors can be added on any faceted model.  

Most of the examples will require the use of the 3Data Expert Base module 
equipped with full set of manipulation (repair, Boolean, extrude, edit triangles, …) 
and texturing/coloring commands for triangulated models. 

The example models have a variable level of difficulty. The models are selected 
due to the errors inherent in them. You should normally not meet models with such 
large numbers of errors if they are designed and outputted correctly from the 
sending CAD system. The models (a cell phone, a human head and the Maya 
demo part) are included in the installation package tutorials/GeomFiles directory.  

All commands and their parameters are explained in detail in the On-line Help of 
the 3Data Expert. If in doubt, please check the meaning of each parameter from 
the On-line Help. 

If you are using 3Data Expert the first time, you should reserve about two hours to 
go through all examples. We also recommend that you study the Quick Start Guide 
and the tutorials before attacking these more problematic models. 
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The operations given in boldface in this document are commands which affect the 
geometry of the part in question and must be run by the user in the given order to 
get the results show in this document. Several other commands, like viewing and 
clipping, are not given in boldface but must be used to be able to generate a correct 
result. Terms given in italics indicate file names, commands, shell names, surface 
names and parameters for different commands.  

The full tutorial set for 3Data Expert contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu. Please check 3Data Expert 16.0: Quick Start Guide for further 
information. 

The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its sub-folders (GeomFiles, Tutorial 1, Tutorial 2, etc.) in 
the 3Data Expert (or product in question) installation directory.  
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Chapter 2 – The cell phone model 

The first model to repair is a cellphone model (tutorials/GeomFiles/cellphone.stl) 
You will need the 3Data Expert Base or Lite module to complete this exercise in 
about 10 minutes. You can also use the Dimensions module until paragraph 
Combining the cellphone components which requires the Boolean commands. 

Now  

− input the STL file with File > Open command you can see the model 
on the graphics area. 

For each inputted file the software will ask for the units if not available in the input 
file.  

− Select default millimeter units and press OK 

When the units are set the software will ask for the Operation Mode: 

 

The Operation Mode Window gives a reminder on the possible modification 
processes you can perform on a faceted model and allows you to select the correct 
set of tools for any operation. Note: if you do not see the Operation Mode window, 
please make sure the Show operation mode dialog when: opening is On in the Edit 
> Preferences General Tab. 

3Data Expert may also automatically fix the model if Operation Mode window 
setting is turned Off and Auto repair when dialog is hidden checkbox is turned on. 
In that case you can skip the following fix model steps. 
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The differences in the triangle colors on the display (blue vs. pink) are since the 
triangle normals are not consistently oriented. The blue color marks the inner side 
(inverted normal) and pink color marks the outer side (normal) of the triangles.  

− Select Fix Model mode and let the software run until you will see the 
following message: 

 

 

This is the result of the automatic analysis before the Auto Repair (the same result 
can be achieved through Fix Model > Verify Shells command if the Operation Mode 
Window is not used).  

We can see that most of the 210 shells are separate from each other (red gap 
curves) but obviously should be connected into one single shell. You can zoom 
and rotate to investigate the model when the Auto Repair dialog is visible.  

Auto Repair operation parameters are automatically set for optimal repair result. 
Normal repair will stitch nearby open shells together (more than 70% match with 
the open edges) and Fill gaps will finally fill remaining larger gaps.  

− Press Yes to fix automatically as much as possible 

 

After a while you will see the Auto Repair result:  
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− Press OK to close the window. 

We have now managed to combine over 200 separate (open surface) components 
into 6 useful components. Note that three shells have a green-with-warning icon: 
they contain errors which probably do not cause problems with the 3D printers for 
which 3Data Expert is targeted. Let’s, however, for each of these shells, look at 
the error descriptions shown in the lower-right corner Help text window: 

 

 

 

The first shell is the biggest one and contains most of the errors. The errors can 
be eliminated with a couple of Fix Model > Delete Errors and Fix Model > Repair 
Shells iterations. Even if the model is already printable, in the following we will go 
through the repair steps, and finally use the Boolean operations to form one final 
part.  

Note: if you have more than 6 shells in the Model Tree, you may delete the small 
extra shells caused by overlapping surface areas in the model.  

Workspace 

When the file has been read in, a workspace is automatically loaded, based on the 

current Print configuration setup. It can be made visible or hidden with the  icon. 
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The workspace is not needed for the lessons in this tutorial, so you can keep it 
hidden. 

If the loaded test model does not fit in the workspace, an error message about that 
is first shown. You can just click OK to make it disappear. 

 

Useful Toolbars 

Before continuing with the exercises, you may want to turn on the Transform 
Toolbar, 

 

the Errors Toolbar 

 

and the Dimensions Toolbar: 

 

They are all turned on via the View > Toolbars menu (if not already on), and they 
contain shortcuts to useful repair commands.  

 

Locating and removing errors in the body 

Let's now give a more descriptive name to each component: body, cylinder, 
upbox1, upbox2, downbox1 and downbox2. The first task is to repair the body 
component: 

 

The body component has several errors due to the bad quality of the input data. 

− Select the body shell 



3Data Expert 16.0: STL and VRML repair examples 

 Page 10 

After selecting the body shell in the Model 
Tree, the Help Text window on the right 
gives a textual description on the errors.  

In the image above we can see certain error 
areas, like a large, inverted area. Most the 
errors are not clearly visible; these are 
caused by the other components 
intersecting the body. Also, in the image 
below we can see areas which have both 
error triangles and complex gaps caused by 
duplicate and overlapping surfaces in the 
original input model (if you removed more 
duplicate/overlapping surfaces in earlier you 
may have less errors now).   

 

− give command Fix Model > Locate Errors or press the shortcut 

 

button. You will see the Locate Errors dialog appear. Turn on Highlight warnings 
and error triangles of the body shell are highlighted (here we have zoomed to 
clearly see a couple of errors): 
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The Locate Errors dialog gives exact information on the currently highlighted error 
triangle (or gap) in the Current error section. Also, the surface containing the error 
triangle is automatically selected in the Model Tree when the errors are traversed 
with the Previous and Next buttons.  

We will now use the Previous and Next buttons to find each area with error 
triangles and use surface selection and deletion as well as Fix Model > Triangle 
Edit to remove or add triangles to enable correct fixing with the next call to Fix 
Model > Repair Shells command. We will not use the Delete button available with 
Locate Errors tool this time, now it is better to use the red error triangles to indicate 
the error areas for surface selection and deletion.  

 

− Press Next button in the dialog and you should see the following error 
fitted in the middle of the screen: 

 

 

When the model is shown with the viewing direction in the previous window, the 
error triangles are behind some surfaces. The Locate Errors tool fits the error area 
to the screen but does not change the viewing direction. 

To see the error triangles more clearly, you can 
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1) zoom out the model 
(using the mouse wheel 
or middle mouse button 
MMB) 

2) then turn the view to the 
opposite direction (with 
RMB rotation around 
selected point) 

3) and zoom in again 
(using the mouse wheel 
or MMB): 

   

 

This error area is caused by some overlapping surfaces in the model. You can 
have a more detailed explanation on each error (red) triangle on the screen:  

− Make sure you have set Surface selection mode 

 

− Click on a triangle with the right mouse button on the and choose 
the numbered element (triangle 31394 in this case): 

   

 

The dialog appearing will give more detailed information on the errors in the clicked 
triangle. We will follow the first help to remove triangles or surfaces to reduce 
errors.  
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Let's now start deleting bad surfaces and triangles in the error area. When we 
delete small overlapping surfaces, the number of errors diminish and soon we will 
only have gaps which can be fixed automatically.  

You may turn on the shaded+wireframe view mode by pressing the  icon with 
the left mouse button (LMB) and also make sure the selected object bounding box 

is displayed by clicking  icon.  

Then  

− click with the LMB (left mouse button) on the middle of the error area 

to get an error surface selected:  

 

− Then give command Edit > Delete to remove the bad surface or press 

the Delete shortcut button:   

Then reselect a new surface at the bad area. When removing surfaces always try 
to remove the smallest error surfaces at a given error area first. Also, you 
should try to first remove surfaces surrounded with red gap curves. You may need 
to click several times on the same mouse location to figure out how many small 
surfaces are located in the same area. When you click with the LMB (or the SPACE 
key) without moving the mouse, small surfaces below the visible surfaces get 
selected. You will notice that the error status is updated after each deletion: 
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− Now repeat selection and delete combination until all overlapping 
triangles are removed (again, try to delete the smallest error areas first): 

One or several gaps are left in the error area. These gaps will be fixed, even large 
ones, during the next run to the Repair Shells command done later. Now we will 
go through the rest remaining error areas to perform similar bad overlapping or 
intersecting surface removal.  

You can easily find the next error area by pressing the Previous or Next buttons in 
the Locate errors dialog. Or you can select the next area visually. Select and 
remove surfaces until you have removed all bad surfaces in the area.   

− You can close the Locate Errors dialog now. 

 

Next, remove rest of the errors in a similar manner. However, using the Fix Model 
> Delete Errors command, followed with Fix Model > Repair Shells is 
normally much easier to use; you can repeat the Delete Errors – Repair Shells 
(with default parameter values, usually) commands until you get rid of all errors 
and warnings (or at least those which may affect your AM process). 
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− Now select the body shell and run the Fix Model > Repair Shells 
command on to fill in the gaps generated during the surface removal. 
You can use automatically proposed parameters: 

 - Press OK to start the command. 

The default parameters force detection of tiny shells. If these are found, the 
removal dialog is shown: 

 

You can safely remove the tiny shells. After the command, if important shells have 
been removed, you can undo the command and rerun repair without removal of 
tiny shells or with different parameters.  

Finally, we will get a body shell without any errors: 

 

If you encountered problems producing the correct body, you can continue with 
the file tutorials/GeomFiles/cellphone-body-repaired.3de stored in the distribution 
package.  
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Note: If you are still left with some errors and seem not to get forward, you may try the Fix Model 
> Edit Triangles command to remove individual triangles from areas with errors. Just start the 
command, click on triangles with LMB and finally RMB to remove them to make clean gaps for the 
automatic gap filling with Repair Shells command.  

The model will still contain a zero-volume area where two flat surfaces are on top 
of each other. Depending on the receiving 3D Printing system these areas must 
be removed or left into the model.  

 

We are currently in the Normal Error Filtering mode. If you set on the Strict Error 
Filtering through the Edit > Preferences > File Fixing settings, you will see more 
errors and remove them using similar techniques as above.  

 

 

More errors shown with Strict mode: 
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These steps are left as an exercise to the user: 

− Select and remove two overlapping surfaces in the displayed area 

− change back to Normal Error Filtering mode.  

− run Repair > Shells on the body shell with default parameters 

 

 

 

We now have 6 printable shells in the Model Tree. Depending on the receiving 3D 
Printing process, we may need to connect them into one connected shell.  

 

Combining the cellphone components 

The Modify Faceted > Boolean command is used for combining the 6 components 
into one correct STL file. 
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We will first combine the cylinder with the body. As we can see in the image below 

(using clipping with the  icon) the two components are slightly intersecting:  

 

We can connect these two shells into one by simply using the Modify Faceted > 
Multiple Join or the Modify Faceted > Boolean command. We will use the Multiple 
Join command.  

− Select the shell 1. body and shell 6. cylinder as shown in the image 
above. 

− Give command Modify Faceted > Multiple Join 

 

Soon you are asked to Remove original parts: 

 

− Press Ok to Remove original parts and to commence the Boolean 
operation. 

Soon the result will appear, the two shells are connected, and the result is stored 
in a new shell, Multiple sel (Multiple Join): 
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Now we will connect the fixtures upbox1 and upbox2 shells to the body. The 
fixtures are too far from the body, so we either need to move them towards the 
body or we need to generate extra material on the surfaces facing the body. Now 
we will generate more material on the surfaces. Extra material is added with Create 
Geometry > Extrude Surface > from Surface command.  

We will add material on the upbox1 shell, selected below in the Model Tree: 

 

To be able to create a Boolean result, we will add material to the surface which 
faces the body shell.   

− Fit the shell with LMB +  icon or double-clicking the shell in the Model 
Tree 

− make sure you are in the Surface selection mode: 

 

− Then rotate the eye point to see the surface facing the body shell 

− and select surface graphically: 

 

 



3Data Expert 16.0: STL and VRML repair examples 

 Page 20 

− Then give command Create Geometry > Extrude Surface > from 
Surface 

You will see the following parameter dialog:  

 

− fill in the values above (thickness 0.01 mm and untick the use default) 

− press OK 

After a while you will see the extrusion result: 

 

The command moves the selected surface to the (average) normal direction of the 
selected surface(s) and creates new edge triangles to keep the fixture solid. Now  

− use the multi-selection (Ctrl + LMB) to select the body and the 
upbox1 shell 
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− give command Modify Faceted > Multiple Join and press OK when 
requested. After the joining we have the two shells properly combined in 
a single shell, as we can see in this clipped view: 

 

The result now has the two shells connected into one shell 4. Multiple sel (Multiple 
Join).  

Connect the upbox2 shell to the body in similar fashion,  

− select the surface facing the body 

− extrude material with the Extrude > from Surface with the same 
parameters used in the previous extrude 

− run Multiple Join to connect the shell to the body 

After connecting the upbox2 shell you should have the following composition in the 
Model Tree: 
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In the last Boolean step, we will connect the downbox1 and downbox2 to the body.  

− Use multi-selection to select all three shells 

 

 

If you do some visual checking with Clipping tool, you will see that the components 
are tangential: 
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Most of the time, the Boolean operations with 3Data Expert can handle tangential 
surfaces, i.e. to connect them correctly. Just proceed with  

 - command Modify Faceted > Multiple Join for the three shells 

After a while you will see the three shells connected into one body shell: 

 

If the result of the Multiple Join command is not correct, you can use the same 
extrude method as with upbox1 and upbox2 also for downbox1 and downbox2. 

The correct model is stored in the cellphone-repaired.3de file in the distribution 
package.   

 

Conclusions with the cellphone model 

The cellphone model can be repaired using the 3Data Expert software within 5 - 
10 minutes by an experienced user. Stitching gaps, adding material and using 
Boolean allow us to fix the cellphone file in a few minutes. The output result is a 
fully fixed STL model for 3D Printing or Additive Manufacturing.  
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Chapter 3 – A human head 

The second example will be a VRML model, a human head. The head model can 
be repaired using the 3Data Expert Base or Lite modules, and it should take less 
than 5 minutes. The extensive use of Boolean operations makes this example 
unsuitable for the Dimensions module; however, the Dimensions module can be 
used until paragraph “Repairing and combining the head and the eyes”. You may 
also want to try the self-intersection removal in paragraph “Repairing and 
combining the head and the teeth” on page 44 if licensed to the Dimensions 
module only.  

Start by  

− inputting the VRML file gary_front_profile_bwrl.wrl with File > Open 
command 

you can see the model on the graphics area. For each inputted file the software 
will ask for the units if not available in the input file. As usually, accept the 
suggested unit (millimeter) and, from the Operation Mode, proceed to the Fix 
mode. 

Analyzing the head model automatically 

In the Fix mode, the software automatically analyzes the model for errors as well 
as orients the normals consistently. 

After a while the analysis result is shown in the Auto Repair dialog status message:  

 

After the analysis the surface normals are corrected and the outer surface color is 
changed to pink, the inner surface color remains light blue.  
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The model has 6 shells, each with errors. The software asks you if you wish to run 
Auto Repair immediately.  

 

Visual inspection of the errors (gaps) in the model suggests that we should not run 
the Auto Repair with the Simple repair mode, because it would repair each open 
shell separately into a solid shell. The gaps in this model at the mouth / lip region 
show that closing them may generate separate shells where shells should be 
connected to each other at open edges (lips vs. mouth).  

If Auto Repair is run with Normal repair, the mouth / lip open edges will be 
connected. You may do a faster repair just by running the Auto Repair with Normal 
mode and skipping to the chapter Repairing the teeth.  

However, to learn some important repair techniques, do the following:  

− Press No to Auto Repair to start a more careful examination of the 
errors. 

You will see the status window appearing: 

 

 

This indicates that each shell has errors, and we should use Model Tree and Help 
Text to repair the model.  

− Press OK to close the window and 

to see the Command Tip window (if not turned off earlier).  

− Press Close when ready reading the tip, if visible. 

Before going to a more controlled use of the repair commands you may want to 
take a look at the real colors in the VRML file. For that you should turn on the 3D 

Color Printer mode for a second. Press the    icon to see the original VRML 
texture map colors:  
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3Data Expert can repair and manipulate fully colored and textured models for 3D 

Color Printing. Now press the    icon again to get back to the Repair color mode.  

 

 

The Model Tree on the left-hand side of the display 
area contains the directory to the geometrical 
information for the model. This model contains 6 
shells (e.g. 1. gary_front_prof (Verified), ...). Each 
shell contains Verified triangle surfaces (press +-
icon to see the 1. Verified, 2. Verified. etc. surfaces 
inside the first shell). The texture information for the 
VRML data (.jpg images) is stored inside each 
surface. 

 

If you select each shell separately you will see that they represent the eyes, teeth 
and mouth for the head model. After initial verification the shells are ordered by 
surface area in descending order.  

Now select different shells in the Model Tree and see the Help text window in the 
bottom of the Fix Help Tab on the right-hand side of the screen. Select the 1. 
gary_front_prof (Verified) shell with the left mouse button from the Model Tree:   

 



3Data Expert 16.0: STL and VRML repair examples 

 Page 27 

The message in the Fix Model Tab Help text 
window tells that there are several  
intersecting triangles (about 151) and gaps (4) 
in the selected shell. Gaps are shown as red 
curves on the graphics area and stored in the 
Gaps element in the end of each shell in the 
Model Tree (for example, open the 1. 
gary_front_prof (Verified) component and use 
the vertical scrollbar to scroll to the end of the 
component to see the Gap element). The 
intersecting triangles are shown with red color 
in the display area. The intersecting triangles 
are mostly generated by intersections 
between the eyes and mouth parts with the 1. 
shell.  

Below the status information the set of 
possible commands to fix the model are 
presented. There may be one or more 
commands and the first is the most likely 
action to take. Anyhow, you should also use 
visual inspection to finally decide the 
command to run.  

 

 

The input file is divided into 6 different shells in the Model Tree; the original head 
consist of these disconnected components (eyes, teeth, mouth …). In the sequel, 
all gaps will be closed and the components will be connected into one correctly 
oriented part.  

Analyzing the head model visually 

Some visual inspection very quickly shows us that the 1. shell (head) should be 
connected with the inner mouth shell (2. shell). In the image below the two shells 
are displayed (non-displayed shells are grayed out in the Model Tree) and clipped 
to display the inner structure of the model (the Clipping Window can be displayed 

by pressing the   icon):  
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We can use different visual aids to define the order how to fix and combine the 
different components together (see the image above). Several viewing commands 
are available in the View menu as well as the Viewing Toolbar and Clipping 
Window functions do determine the best way to go forward. For example, we can 
have a look at the model using clip form +X direction and a thick light blue clip 
curve, as seen above.  

Investigating the verified model visually will show us that one possible way to go 
is to repair and combine the parts in the following order: 

• stitch head and mouth into one correct shell 

• repair eye shells 

• repair teeth shells 

• join all shells with Multiple Join command into one shell 

 

Before starting the repair operations, lets 

− rename the different shells with more descriptive names 

with right mouse popup menu on the Model Tree item + Rename command. This 
will help us to keep better track on different parts during the repair process. Below 
we can see the renamed components.  
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Repairing and combining the head and the mouth 

With the head and the mouth we will use the automatic Fix Model > Repair Shells 
command to combine the mouth to the head at the lip area. Stitching the mouth 
edges into the lips (see below) will produce a desirable result. 

We can see that both the disjoint shells are more or less at the same distance from 
each other along the open edge. The approximate distance can be measured 
using the Dimensions > Distance command and it will give approximately 0.05 

units (you can also use the  icon to start the Distance command).  

Before running the Fix Model > Repair 
Shells command we will use the multi 
selection (Ctrl + left mouse button (LMB)) 
to select both head and mouth 
components in the Model Tree.  

 

Now  

− select the two shells with multi-selection, first the mouth, then the head 
(the last selected shell will give the name to the result) 
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− run the Fix Model > Repair Shells command from the menu or use the 

command Fix Model Tab shortcut  button.  

 

You will see the following parameter window: 

 

 

To get good results, we must give correct parameter values for the repair process. 
As seen above, normally we want Check for triangle errors as we are changing the 
geometry and we want to know the possible errors after the repair. 

• Select the Normal repair mode. This will cause the two shells to be 
connected during the repair at the open edges  

• Fill gaps in all shells will cause all gap to be filled (there are actually no 
flat/open shells in the selection) 

Stitch gaps smaller than 0.071345 is automatically calculated according to the size 
of the selected shells. According to our measurements earlier this will connect the 
shells together by stitching the edges together, i.e. all segments which are closer 
than 0.071 units from each other will be combined. Fill large gaps, smaller than 
and value All will fill the remaining large gaps (neck and eye slots) to form a solid 
model.  

Note: you must be careful when filling the Stitch gaps smaller than value. If a too large value is 
given some edges may be connected to edges too far away, causing new errors.  

The Advanced parameters are not needed with this example.  

With the head model we will accept the other parameters seen in the image below. 
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− press OK to start the Repair Shells command 

 

After a while we will see the correct result and the message 

 

The original parts have been deleted from the Model Tree and the result will be 
stored in the end of the Model Tree, 5. head (Repaired).  

(If the name of your result shell is 5. mouth (Repaired), you selected the two shells 
in opposite order. In that case you should rename it to head).  

− Press OK to close the message dialog 

 

Repairing the eyes 

In the next step we will repair the eye ball shells to prepare for combining them 
with the head shell later in the process.  

First, we will  
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− select both eye shells, left eye and right eye, 

for the second Fix Model > Repair Shells command. The selected sells are fitted 
on the graphics area in the image below:  

 

 

− Give command Fix Model > Repair Shells  

The parameter dialog is displayed.  

We will use the default parameters: 

 

 

− Press OK to run Repair Shells command 

− Press OK to close the following status dialog 

 

And you will see two correct eyeballs in the end of the Model Tree: 
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Repairing the teeth 

Next, we repair the teeth shells to be connected to the head shell later. First we 
will run Repair Shells command individually on both teeth set, upper teeth and 
lower teeth, to get a solid STL data for the following Boolean operations.  

− Select the upper teeth shell and 

− run the Fix Model > Repair Shells on the selection.   

Use the automatic parameters.  

Note: Repair Shells is the second preferred command in the Help Text window in the Fix Models 
tab (first proposal Join Gaps cannot be used as there are no similar gaps close by). 

− Press OK to start the Repair Shells command 

After a while you will see the result 

 

The software reports 23 Intersecting triangles error. A closer investigation (red 
triangles in the image below) shows that the intersecting triangles are piercing 
through the outer surface.  
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In the Fix Model Tab Help text window the most recommended repair action is to 
run Remove Self-intersections command.  

− Run the Fix Model > Remove Self Intersections command on the 
upper teeth shell now. 

The command can also be started from Fix Model Tab shortcut button. 

 

After a while the self-intersection result is displayed with Tip window (unless turned 
off earlier):  

 

The Tip window (if visible) indicates that the shells preselected after the command 
is run can be deleted. These are the small pieces generated by the self-intersection 
removal and can normally be deleted from the result; the largest shell is the one 
before the preselected shells and is normally the correct result. Anyhow, you 
should always visually check that the correct extra shells are removed. With this 
example the visual check also supports the proposed removal of the shells 6 to 10, 
as seen on the next image: 
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− Delete the extra shells with Edit > Delete command 

or by pressing the Fix Model Tab delete shortcut button: 

 

The software now recommends the you run the Repair Shells command to fill the 
gaps generated during the Remove Self-intersections command.  

− Run Fix Model > Repair Shells command with the automatic 
parameters now to generate a solid upper teeth shell: 

 

The lower teeth are handled in the similar manner. First  

− run the Fix Model > Repair Shells command to close all gaps 

on the lower teeth component to make it solid. Once again, there are self-
intersecting triangles which are removed by  

− running the Fix Model > Remove Self-intersecting command. 

After the self-intersection removal the extra small shells 6 to 14 are again deleted:  
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− Delete the selected small shells now. 

− Run Fix Model > Repair Shells on the shell 5. To fill the gaps and 
create a solid shell. 

− Press OK to close the status window 

− give View > Fit for the root node All 

 

Now we will have a model with 5 correct shells to be connected into one final shell.  

 

We will use multiple selection to select all parts and then run the Modify Faceted 
> Multiple Join command on them.  

− Multi-select all shells in the Model Tree and 

− Start Modify Faceted > Multiple Join on the selected shells: 

 

− Press OK to run Multiple Join with Remove original parts 
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A progress bar is shown for each shell to connect (1/5, 2/5, … 5/5) and soon you 
will see the correct head (if necessary, rename the result shell to head shell): 

 

 

The Fix Model Tab Help texts shows that the model is correct too:  

 

 

Outputting head STL and VRML files 

The STL output of the file is straightforward, just select the model and give File > 
Save As command with the STL option. Also, outputting to 3D Color Printing can 
be done easily by selecting either VRML or ZPR file formats.  

The correct file tutorials / GeomFiles / head-repaired.3de can be found in the 
installation package.  
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Chapter 4 – The Maya model 

The third model to fix will be a test part generated with Maya software 
(maya_three_d.wrl in the example package). The maya model fixing should not 
take more than 10 minutes with 3Data Expert.  

Start and 

− Open the file maya_three_d.wrl with File Open dialog. 

After the input we will immediately see that the model is not oriented correctly, 
there is a lot of blue color inside (inverted normal) visible amongst the material 
colors (normal side) inputted from the VRML file.  

 

− As usual, accept the units and proceed to the Fix mode to start the 
analysis; after a while you will see the Auto Repair dialog with Model 
status message: 
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The normals are now consistently oriented and the repair color is set to the normal 
sides of the triangles (the original material colors are stored for the 3D Color Printer 
mode). There are also a few gaps visible on the screen. We can see that there are 
errors close to the “created with” text. Running Auto Repair may join the small 
details in the letters in a way which may cause difficulties later with the Boolean 
operations, so we will  

− press No to the Auto Repair question 

The familiar status message appears:  

 

− Press OK to close the window, also Close the Tip window appearing if 
set On through the Help menu.  

We are left with two shells, as seen here: 

 

 

We can immediately remove the second shell: 

− delete 2. maya_three_d shell from the Model Tree 

 

Now we will select the shell 1. maya_three_d (Verified) from the Model Tree and 
have a look at the Help text in the Fix Model Tab.  
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The indicated errors, 167 overlapping 
triangles are typically the most difficult to 
fix. This may require removing surfaces 
manually and then adding some triangles 
to help correct filling for the gap. Also, re-
trimming of some surfaces against each 
other is sometimes required.  

The 14 intersecting triangles are either 
fixed by Remove Self-intersecting 
triangles command or Delete triangles / 
Repair Shells pair. Anyhow, now we must 
first remove the overlapping triangles to 
see the real situation concerning the 
intersecting triangles.  

 

To start, let's rename the shell to shorter name, maya. If you now open the Model 
Tree for the maya part, we can see no textures as was the case with the previous 
head model. Now the model colors are given through the material definitions in the 
VRML file.  

You may now try to press the 3D Color Printer  icon to see the true colors of the 
model:  

 

Return to Repair color mode by pressing the  icon again before continuing.   

Repair steps for the Maya model 

The errors in the model are caused by erroneous triangulation of surfaces at the 
intersections of different model components. First you should investigate visually 
how serious the errors are.  

A short investigation reveals that we cannot just delete the erroneous triangles with 
Fix Model > Delete Errors > All error triangles command. Instead, we need to do 
some  
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1) The “created with” text requires to be re-connected to the part for correct 
STL/VRML file generation.  

2) The box below the “created with” is not correctly trimmed to the curved 
surface attached to it.  

3) Manual triangle removal and addition at the string “graphics” character 
borders to help the automatic repair to produce the correct result in the end. 

4) Gaps should be filled with automatic repair. 

Let's start with the worst problem, re-connecting the “created with” string.  

 

Connecting the “created with” string 

The string “created with” needs to be re-connected to the maya shell first. If you 
take a look from X axis and use clipping, you will see that the text is on a flat 
surface. In this case we can use the new flat polygon area fill functionality available 
with the Repair Shells command. In the clipped image below you can see that the 
gaps are on the flat plane: 

 

We will first clean up the planar area surfaces the text is attached to. Before 
selection make sure the Selection mode is in the Surface selection mode: 

 

Then 

− take a view from X axis direction 

− use Alt + LMB rubberband selection to select the surfaces in the flat 
plane as seen below 
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When the mouse is released, the surfaces at the plane are selected: 

 

 

And from another viewpoint: 

 

Then 

 - give Edit > Delete command to delete all selected surfaces 
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Now  

− select the maya shell 

− give the Fix Model > Repair Shells command to fill the gap between 
the text and the surrounding area 

Soon you will see the parameters dialog: 
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The Flat polygon area fill, set on by default, will connect the flat gap polygons at 
the letter bottom edges to the surrounding box edges. All polygons lay in the same 
plane and the software use a special algorithm to fill between the separate 
polygons automatically.  

 - press OK to run Repair Shells on the maya shell. 

The result on the text area is a perfect triangulation between the letters and from 
the letters to the surrounding square gap.  

 

 

Fast visual inspection shows that the “created with” string is now correctly 
connected to the maya component.  

 

The maya model would be printable with 
any 3D Printing system with the current 
state. Anyhow, there are still a few 
overlapping and intersecting triangles 
and we will fix them for the completeness 
shake in the sequel. Also, some thin 
triangles may have caused inverted 
surface area to appear. This will also be 
fixed in the sequel. 
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Repairing the text base box 

To locate the remaining errors, you can either look for the red triangles on the 
screen or use the Locate Errors command to highlight the error triangles with 
yellow edge color and to fit them on the middle of the screen. Locate Errors tool 
will help you to pinpoint any error triangle or gap in the model.  

− Give Fix Model > Locate Errors command or press the Locate Errors 

 button in the Fix Help Tab.  

The Locate Errors Window is displayed and error triangles highlighted on the 
screen. The dialog will give info on the total number of errors in the selected shell, 
Previous and Next buttons to select and fit the next error on the display area, error 
type for the currently selected error triangle as well as buttons to go to the next or 
previous Shell with errors: 

 

 

Press the Next button on the Locate Errors dialog until the following error triangle 
is highlighted on the screen:  
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We will now clean up this overlapping triangle and the area surrounding it. You can  

− close the Locate Errors dialog now by pressing Close button. 

 

The box feature in the model has some overlapping triangles on the upper face, 
as seen here:  

 

These errors cannot be removed 100% reliably using automatic Remove Self-
intersections command due to the tangential intersection conditions. Now we will 
remove a few triangles manually and then let the Fix Model > Repair Shell 
command to Fill all created gaps.  

 

− Start triangle removal with Fix Model > Edit Triangles command or 
using the Fix Model Tab shortcut button: 

 

Remove enough overlapping triangles from the error area, as seen in the next 
image.  

You could also use Surface selection mode and LMB selection with Delete to get 
rid of extra surfaces in the area. 
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To finish the fixing at the “created” string, have a look at the bottom of the base.  

− Select all red triangles and delete them also on the down surface of 
the box to allow the automatic repair to fill the gap correctly: 

 

 

You may use the mouse wheel zoom and middle mouse rotation during the Edit 
Triangles command to get a better view to the delete triangles if necessary. After 
the removal the gap should look as seen here:  

 

After deleting the triangles, you can close the Triangle edit mode. 

Then run  

− Fix Model > Repair Shells command and the corrected area is 
displayed: 
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Repairing the “graphics” string 

To locate the last remaining errors we should use the Fix Model > Locate Errors 
tool again.  

− Give the command Fix Model > Locate Errors to open the Locate 
Errors dialog or press the Fix Model Tab shortcut 

 

button. Error triangles in the model will be highlighted with yellow color as seen on 
the image next page: 
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The last errors are at the letter 'c' in the graphics string. Press Next or Previous to 
zoom into the error area and the close the Locate Errors dialog. The errors 
around the letter 'c' are similar to the previous two errors we have fixed:  

 

− Open Fix Model > Edit triangles tool and 

− remove the overlapping triangles with LMB selection + RMB delete 

Then give  

− Fix Model > Repair Shells command for a gap filling and you will have 
a correct maya model. 

 

Note: You may find a new area or areas at the letter 'p' with similar errors after the last repair, just 
remove the overlapping or intersecting triangles in that case and rerun the Repair Shells once 
more. Or use Fix Model > Edit Triangles to clean up the error triangles, simplify the gaps and rerun 
the Fix Model > Repair Shells until there are no errors.  
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Outputting the Maya model 

Once again, STL, VRML and ZPR output is straightforward File > Save As 
operation.  

The correct file tutorials / GeomFiles / maya_three_d-repaired.3de is available in 
the example package. 

If your goal is to take the model to 3D Color Printing, you will need to fix some color 
errors created during the topology fixing. Model coloring is described in detail in 
the “Working with Colors” (through the Help menu). 
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Chapter 6 – Conclusions 

Congratulations for reaching the end of this repair example document! By going 
through the example models you have learned a lot of the advanced STL and 
VRML model fixing functions in the DeskArtes 3Data Expert. The handled models 
are difficult and in the everyday work you should not need all the skills acquired to 
prepare parts to be build. Anyhow, when a difficult model comes you will now know 
what do with it! 

We have shown that the DeskArtes 3Data Expert can be efficiently used to fix even 
most difficult geometrical problems. Investment in the 3Data Expert software will 
pay itself back very fast due to increased throughput of the 3D Printing system or 
seamless STL model transfer to simulation software. 

There are several other commands available in 3Data Expert for generating and 
handling triangle models. To know more about these commands we recommend 
you to go through the example documents available through the Help > Tutorial 
Documents command. 

Thank you for spending your time with these exercises. We wish you pleasant and 
productive moments with the software in the future and also ask you not to hesitate 
to contact us at DeskArtes (support@deskartes.fi) if you have any questions 
concerning this manual or 3Data Expert in general.  
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