
3Data Expert 16.0: Tutorial 1 - Working with 3D Models 

 

 

 
DeskArtes 

3Data Expert 16.0 
 

Tutorial 1 - Working with 3D Models 

 

 

 



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

  Page 2 

First Edition  

Ismo Mªkelª: ñ3Data Expert 16.0: Tutorial 1 - Working with 3D Modelsò.  

February 2026 

Copyright  © 2026 DESKARTES. All rights reserved.  

DESKARTES reserves the right to revise this publication and to make changes from 
time to time without the obligation to notify any person of such revisions and 
changes. 

Trademarks  

The DESKARTES name and the logo are trademarks of DESKARTES Oy. Other brand 
and product names are trademarks and registered trademarks of their respective 
owners. 

Contact Address  
DESKARTES OY 
Takomotie 8 
FIN-00380 Helsinki 
Finland 

https://www.deskartes.com 



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

 Page 3 

Table of Contents 
FOREWORD ................................................................................................................................................. 4 

Modules ................................................................................................................................................. 5 
LESSON 1 ï BASIC USER INTERFACE PROPERTIES ....................................................................................... 7 

The Free module  .......................................................................................................................... 9 
Sandbox mode exceptions ..................................................................................................................... 9 
File input ............................................................................................................................................... 9 
Model Tree ...........................................................................................................................................14 
Basic viewing commands .....................................................................................................................15 
Selecting objects...................................................................................................................................16 
Selecting shells, surfaces and triangles graphically ............................................................................17 
Display Area menu ...............................................................................................................................19 
Object properties .................................................................................................................................19 
Dimensions and Annotations ...............................................................................................................20 
Repairing the slubox model..................................................................................................................23 

LESSON 2 ï FULLY AUTOMATIC STL FIXING .............................................................................................24 
Auto Repair process for STL files ........................................................................................................24 

LESSON 3 ï STL FIXING .............................................................................................................................27 
Verifying and repairing the STL model ................................................................................................27 
Verifying and repairing, take two ........................................................................................................28 
Using Repair Shells command .............................................................................................................29 

LESSON 4 - SPLITTING AND COMBINING STL ............................................................................................33 
Splitting the dino model .......................................................................................................................33 
Creating the pins ..................................................................................................................................36 
Saving the result ...................................................................................................................................39 
Using Lap Joint to connect thin parts ..................................................................................................40 
Adding Lap Joint ..................................................................................................................................42 

LESSON 5 ï POSITIONING PARTS ................................................................................................................46 
Print Configuration ..............................................................................................................................46 
Moving parts into the platform ............................................................................................................49 

LESSON 6 ï NESTING .................................................................................................................................52 
3D Nesting regular components ..........................................................................................................52 
3D Nesting irregular components ........................................................................................................55 

LESSON 7 ï ADDING 3D TEXT ...................................................................................................................60 
Creating 3D Text..................................................................................................................................60 
Adding 3D Text to multiple parts .........................................................................................................62 
Adding 3D Text on curved surfaces .....................................................................................................65 

LESSON 8 ï GENERATING AM  REPORTING ................................................................................................68 
Production Screenshot command .........................................................................................................68 
Generate Report command ..................................................................................................................69 

LESSON 9 ï PREPARING FOR 3D PRINTING ................................................................................................71 
Making Hollow models ........................................................................................................................71 
Hollowing with Scan Offset..................................................................................................................73 
Creating a 3D Lattice ..........................................................................................................................74 
Making Drain Holes ............................................................................................................................78 
Making tapered plugs with Hole Tool ..................................................................................................80 
Adding thickness by Offset ...................................................................................................................84 
Combining shells using Boolean commands ........................................................................................87 
Generating advanced cuts with Cut Tool .............................................................................................89 

LESSON 10 ï PREPARING FOR SIMULATION APPLICATIONS ........................................................................92 
Starting the reduction ..........................................................................................................................92 
Reducing the rava2 model....................................................................................................................94 
Which reduction method to use? ..........................................................................................................99 
Improving the triangle aspect ratio....................................................................................................100 



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

 Page 4 

CONCLUSIONS .........................................................................................................................................103 

Foreword  

The 3Data Expert 16.0: Tutorial 1 - Working with 3D Models document introduces 
the basic 3D model handling with 3Data Expert 16.0: 3D model viewing, 
measuring, repair, splitting, connecting, adding lap joint, hollowing, drain hole 
generation, Boolean operations, support generation, surface triangulation, data 
reduction and separating shells for different material or color definitions in one part.  

DeskArtes 3Data Expert 16.0 is available as a 64-bit implementation, allowing you 
to handle huge models for Additive Manufacturing.  

The full tutorial set for 3Data Expert contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu:  

 ̧ 3Data Expert 16.0: Quick Start Guide gives a short introduction to model 
repair and splitting for 3D Printing with 3Data. Estimated completion time 
15 minutes. 

 ̧ 3Data Expert 16.0: Tutorial 1 - Working with 3D Models introduces basic 
viewing, measuring, automatic repair, split, connect, hollow, offset, 3D Text, 
Boolean, cut, reduce, 3D nesting, surface triangulation and other model 
manipulation functions available for STL files. Estimated completion time is 
3 hours.  

 ̧ 3Data Expert 16.0: Tutorial 2 ï Working with Colors introduces basic 
automatic repair and coloring for 3D Color Printer users. Estimated 
completion time is 1 hour.  

 ̧ 3Data Expert 16.0: Tutorial 3 ï Separating Shells describes the use of Shell 
Separation commands in 3Data Expert. These commands enable 
separating a part into several shells for different material (shore value) or 
color definitions in a single part. This tutorial is meant only for users who 
have a Base module license. Estimated completion time is 30 minutes.  

 ̧ 3Data Expert 16.0: Tutorial 4 ï Generating Supports for AM explains the 
use of new Generic Supports command and Sand Supports command. The 
support generator can be used to generate supports for DLP, metal, 
stereolithography and sand-based processes. Adding extra connectors to 
prevent parts from warping and bending during the build is explained. Also, 
new slicing, slice preview and slice filling is demonstrated. Estimated 
completion time 1 hour.  

 ̧ 3Data Expert 16.0: STL and VRML repair examples document includes 
more advanced model repair operations with 3Data Expert. Estimated 
completion time with 3Data Expert 2 hours.  
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The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its sub-folders (GeomFiles, Tutorial 1, Tutorial 2, etc.) in 
the 3Data Expert installation directory.  

Additional information and help on other STL manipulation tools can be found in 
the Handling Faceted Files section of the On-line Help pages. These pages contain 
information on verifying, repairing, splitting, offsetting, hollowing and draft checking 
for tooling applications.  

The operations given in boldface  in this document are commands which affect the 
geometry of the part in question or are otherwise important and must be run by the 
user in the given order to get the results show in this document. Several other 
commands, like viewing and clipping, are not given in boldface but should be used 
to enable generation of a correct result. Terms given in italics refer to file names, 
commands, shell names, surface names and parameters for different commands.  

The pictures in this document can differ from the version you get. Most of the 
pictures have been grabbed with the classic theme, while the dark theme has been 
used for some of them. The theme can be changed from Edit > Preferences. 

Modules  

The lessons in this tutorial are organized in such a way that that the required 
software functions increase along the lessons. 

DeskArtes 3Data Expert software suite consists of several products targeted from 
home and DIY use to education and professional Additive Manufacturing: 

- 3Data Expert Free is an entry level tool targeted for viewing, verifying, 
repairing, dimensioning, and communicating 3D geometry information. It 
allows you to input triangle models, create consistent topology, check 
errors, orient normal vectors, repair gaps and self-intersections, edit 
triangles and output STL data for 3D printing, without any cost. In the 
tutorials, when information relevant to the Free module is handled, it is 
marked with  

- AM Expert module (an option to Free and Base) provides automatic AM 
process selection based on part requirements (material, size, accuracy, 
tensile strength, and post processing). The AM Expert database currently 
contains data for 129 professional AM systems, and it is regularly updated.  

- 3Data Expert Dimensions is a simple, economical, and user-friendly tool for 
STL repair and 3D model splitting for machines with a smaller build area. 
The tools include Repair, Splitting and Connect with Pins or Lap Joint. 
Information relevant to Dimensions will be marked with .  

- 3Data Expert Lite includes all standard 3D model preparation tools for 3D 
Printing and Additive Manufacturing. Available tools include geometry 
generation, Boolean and 3D markup commands, Offset, Hollowing, 
Coloring and Texturing, Solidify (aka ñshrink wrapò), as well as Slicing and 
Tool compensation. Optional 3D Nesting makes 3Data Expert Lite a perfect 
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3D data preparation tool for powder-based AM systems. Information related 
to Lite will be marked with .  

- 3Data Expert Base is a professional tool for preparing 3D models for 
Additive Manufacturing and Simulation applications. There are several 
commands for manipulation of both 3D surface models and 3D faceted 
models. These commands include Surface triangulation, STL verification 
and repair, STL Offsetting, Splitting, Connecting, Decimation, Smoothing, 
Solidify, Boolean, Part subdivision, 3D Nesting, Z Compensation, Slicing 
and Tool Compensation as well as STL Coloring and Texturing. Supports 
can be generated for DLP, metal and stereolithography processes. Special 
Sand Support command creates supporting plates for delicate sand parts 
with a push of a button. Information relevant to Base is marked with . 
However, most of the tutorial contents are applicable with Base.  

- 3Data Expert Color ( ) contains a subset of 3Data Expert Base, 
especially meant for handling color models. A variety of color and texture 
specific input formats are handled: VRML, ZPR, 3DS, OBJ, PLY. 3Data 
Expert Color has previously been labeled as DeskArtes 3DEdit Pro. 
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Lesson 1 ï Basic User Interface properties  

This lesson shows you how to do basic file input, viewing, dimensioning and 
verification of surface data with 3Data Expert. 

You will need a license to go through the lessons except the ones marked with  
Before starting the lessons, please make sure you have received and installed the 
software evaluation license from DeskArtes. If you do not have a license yet, it is 
very simple to request a license. First start the DeskArtes 3Data Expert  (or 
Dimensions Expert, etc.) by double-clicking on the icon created on the desktop 
during the installation.  

 

Then go to the Program licenses dialog through Help > Licenses command. There 
you can find the Request evaluation license on-line button.  

 

Press it and it will open the DeskArtes license request page on your favorite web 
browser. Fill in the required fields and press Submit evaluation request button to 
send the license request to DeskArtes. 
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You will receive the 15-day evaluation license within 24 hours.  

When the license arrives, press the Install license code button and Copy/Paste the 
license string into the input field: 

 

Then press OK to accept the license. Finally, restart the software. Now you are 
ready to go ahead with the lessons! 

If you wish to install network licenses, please have a look at the On-line Help (Help 
> Help Topics command) page Installation / Licenses section. 

If you have used 3Data Expert 16.0 earlier in your computer you may want to delete 
the settings file (settings3DE141.das) in your AppData folder: open Windows 
Explorer, type ñ%APPDATA%\DeskArtesò into the address field, locate the settings 
files and delete it, finally restart the program. This initializes the system into its 
basic state and ensures that your results will not differ from the lesson results. 
Please see the On-line Help Installation / Settings page for the location of the 
settings file. 
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The Free module  

Some of the functionality of 3Data Expert does not require a license: you can input 
several faceted file formats (STL, PLY, ZPR, VRML, é), create topology for the 
model, check errors, repair 3D models automatically and manually, as well as 
output the checked data for 3D Printing (STL, VRML, PLY, ZPR). For more serious 
repair work and model manipulation, like split, connect, hollow, drain hole, support 
structure generation etc., a suitable license is required.  

Sandbox mode exceptions  

Certain 3Data Expert functions, like Drain Hole and Hatch Supports, are created 
using a separate background process started from 3Data Expert. In this case some 
antivirus software products may try to restrict the background process executable 
into ñSandboxò mode. This will cause the command to fail. To fix the problem set 
an exception for the background process executable. This is normally done 
through the antivirus software interface where you can change the run mode from 
ñSandboxò to ñNormalò.  

File input  

You can start the 3Data Expert  by clicking on the icon created on the desktop 
during the installation. If no desktop icon is created, use the Windows Start menu 
to search and launch the software.  

 

After starting the system and closing the Message dialogs you will see the basic 
configuration of the 3Data Expert on your screen: menus, different toolbars, and 
the graphics area. Initially, the menus of the Base module are shown. You can, 
however, change between menu setups if you wish to see less commands (like 
hiding those you donôt have a license to run); also, in 3Data Expert Base, you can 
switch between Build Setup and Advanced Editing modes: 
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File input is normally done File > Open command (which deletes any existing 
models from program memory), or you can drag a geometry file into the graphics 
area (which actually performs the File > Insert command). 1 

- Start the File > Open and select  the  Tutorials / GeomFiles folder 
under the software installation directory. 

The file type is chosen from the Files of type dropdown list.  

- Select type STL  files (*.stl) and you will see the list of STL files in the 
GeomFiles directory. 

- Select slubox -gap.stl  from the file list and press the Open  button.  

 

After a while you should see the slubox geometry on your screen.  

 
1 For both file input and output, there are options which can be controlled via File > File Options. 
These will be discussed later. 
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When a model is inputted 3Data Expert allows to check and set the units to the 
part. For example, STL files do not have any unit information in them.  

 - Press OK  to accept the proposed units, millimeters (mm).  

 

You will next be prompted for the Operation Mode2. 3Data Expert has six main 
operation modes: Fix, Modify, Position, Print, Color and View mode. You may have 
a different set of Modes available depending on which module you are running. 

 

The different modes are used for different tasks: 

 ̧ Fix takes you to automatic model verification and repair and contains 
shortcuts to the main tools used for repair work. 

 ̧ Modify lets you change the model geometry with features which are 
necessary or useful for production. 

 ̧ Position contains tools which help you optimize the positioning of 
components on the printing platform.  

 ̧ Print shows tools for preparing a repaired and positioned model for your AM 
printer, such as creating support structures and slicing. 

 ̧ Color displays the tools for painting and texture image addition. This mode 
also checks the model for errors when selected and sets the display into 
ñwhat you see is what you getò display color mode. 

 ̧ View Mode allows you to temporarily view the model and then return to 
Operation Mode selection later (or to close the minimized window). 

You can also simply close the Operation Mode via the top-right close button. 

 
2 In Edit > Preferences, you can turn off automatic features, including the Operation Mode display. 
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The normal way to begin repairing a model is to start with the Fix mode. To start 
fixing  

- press the Fix button (the leftmost one) in the Operation Mode dialog. 

3Data Expert will begin automatic model verification (Fix Model > Verify Shells 
command). The screen is erased, and a progress bar appears. When the analysis 
is ready, Auto Repair dialog with Model status message is displayed: 

 
You will also see the model structure in the Model Tree on the left-hand side of the 
graphics area (see the image below). The model is divided into separate shells 
during verification. In this case we only get one shell (1. slubox-gap (Verified)). The 
shell has errors (i.e. gaps), which is indicated by the red icon in the Model Tree; 
correct shells would have green icons with  or without  a warning sign 
(depending on defined warning settings), non-verified shells with yellow icons . 

The Model status message indicates that there is one verified shell, which contains 
errors. The display shows red Gap curves through the surfaces. You can use the 
viewing commands when the Auto Repair dialog is visible, zoom (mouse wheel) 
and pan (Ctrl + left mouse button) if you cannot see the gap.  

On the right-hand side of the graphics area, you will see the Tools Window. Fix 
Tab on the Tools Window provides shortcuts to the commands available for repair, 
like Repair Shells and Fill Gaps commands. The Help text window at the lower part 
of the Tools Window also contains information useful for the required repair 
actions.   

Auto Repair is normally the best path to follow when repairing 3D models. The 
different parameters for Auto Repair are set automatically, you should normally 
accept them as they are. We will later see examples where the automatically set 
parameter values are changed. Anyhow, this time we are not going for immediate 
full repair (this is done in the Quick Start Guide), instead we will investigate the 
Model Tree, the Tools Window, and the selection mechanisms available in the 
software. 

 - Press No  (in the red circle) to start viewing the model.  
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A status window appears: 

 

- Press OK  to continue to see the Tip Window with useful tips on viewing 
and selection mechanisms. 

 

- After reading the tip you can Close  the window. You may also prevent 
it from displaying in the future by ticking off the User Interface > Show 
Command Tips setting.  

 

Workspace and Print Configuration   

When you open a file in 3Data Expert, a workspace, as defined in the current Print 
configuration is automatically added to the model and shown in the graphics 
window. When opening the slubox-gap.stl, you get a warning: 
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This happens because the slubox-gap model does not fit in the workspace in the 
x- and y-directions. Press OK  to see the model in the workspace. 
The workspace is not needed for the lessons in this tutorial, so you can hide it 

using the View > Show Platform command (or the  icon). You can also hide 

the bounding box with the  icon and change to shaded view with  icon.  

After closing the Tip Window, you will see the model in the graphics area: 

 

The model icon is red to indicate that it has errors (gaps). The different colors of 
the object (pink and blue) on the graphics area are caused by the gap (drawn as 
a red curve in the model). Through the gap we can see inside the part. In the 
default Repair color mode, the outside (normal side) of the surfaces is displayed 
with pink color and the inside (inverted normal side) is displayed with blue color. 

Model Tree  

On the left-hand side of the 3Data Expert window you can see the Model Tree. 

 

In the current contents you can see one shell, 1. 
slubox-gap (Verified). The shell icon is red 
indicating errors in the model. The (Verified) text 
indicates the last command run on the model. 
Above the tree you can see a line of context-
dependent buttons. Three buttons are always 
visible: collapse tree, view/hide object, and fit 
object. 

 

Below the Model Tree you can see information 
about the selected part, for example the number 
of triangles, part extents, volume, as well as the 
original file name and path.  
We will later take a more careful look at the 
contents of the Model Tree. 
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If you need more screen space for the graphics window, you can press F8 to 
open and close the Model Tree window.  

Basic viewing commands  

Try the following commands to become familiar with viewing operations. Note that 
the commands below do not alter the modelôs true 3D coordinates. They only alter 
the eye-point location:  

 ̧ Rotate  the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. MMB rotation is always available. Left mouse button 
(LMB) rotation is available most of the time except when working with 
painting, texturing, curve editing, and transformations. However, LMB is 
mostly used for selecting objects as shown later. In case you do not have 
3-button mouse, you can also use key combination Ctrl + Shift + LMB or 
Ctrl + Shift + mouse wheel (MoW) 

 ̧ Rotate  the model around a selected surface point by pressing the right 
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of 
the model when the RMB is pressed.  

 ̧ Pan the model by dragging with the Shift + MMB (or LMB most of the time) 
(Shift + MMB means pressing the Shift key and dragging with the mouse). 
For panning, you can also use Shift + MoW. 

 ̧ Pan with rubberband by dragging with Shift + RMB. 

 ̧ Zoom in/out  by rotating the MoW. 

 ̧ Zoom in/out with Ctrl + MMB (or Ctrl + LMB).  

 ̧ Zoom to box  with Ctrl + RMB.  

 ̧ Hide all  by pressing the  icon with LMB (or F5) 

 ̧ Show all  by pressing the  icon with LMB (or F6) 

 ̧ Fit the model  by pressing the  icon with LMB (or F7). 

The main viewing command icons reside in the Viewing Toolbar: 

 

Try them out now. The tooltips provide a short description of each icon. Let the 
cursor remain on top of the icon for a short while to see the tooltip: 

 

Also, the Viewing Planes x/y/z toolbar above allows you to select any projection 
direction as the viewing direction: 
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You can show the green selection box around the selected object by pressing the 
Show Bounding box icon in the Viewing Toolbar: 

 

Try also Clipping functionality  through 
the Clipping Tab to look inside the model. 

The Clipping Tab is opened with the     
icon. The clipped area can be displayed 
in different ways, like as wireframe or 
transparent.  

Clipping also enables to extract real time 
slice information from the model. Real 
time slices can be copied to the Model 
Tree for internal model dimensioning with 
the Edit > Save Clip curves command.  

 

 

Selecting objects  

Object selection can be done either from the display area or from the Model Tree. 
Erase the screen and then display the object node ñ1. slubox -gap (Verified) ò 
again  by clicking it in the Model Tree. Now we have done one selection at the shell 
level. This level can also be called as the part or component level, depending on 
the context. Click on the little box with the '+' icon besides the part name. The result 
should look like below: 

 

The node ñ1. slubox-gap (Verified)ò has 
opened and shows the contents of the shell. 
Each shell consists of several leaves, 
surfaces (1. Verified, ...), which all together 
make up the whole list. Triangle surfaces are 
identified with the  icon. An STL model is 
subdivided into separate surfaces along sharp 
edges during the Verify operation, as done 
earlier.  
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Select surface number 3 from the model tree by clicking it with the left mouse 
button (LMB). You can see one of the surfaces displayed with a green Bounding 
Box around it. Now this surface is your current selection (make sure the bounding 

box display is set with the  button.  

The selected surface is also highlighted on the screen: 

 

The model contains errors, one gap. The gap data is also located in the Model 
Tree after the surfaces. Similarly, gaps can be selected from the Model Tree for 
different operations, like Fill Gap command (to be done later).  

 

Selecting shells, surfaces and triangles graphically  

You can also select shells or surfaces from the display area by pointing with the 
left mouse button (LMB). First  

- display the Tools Window by pressing Shift+F8 (if not already 
visible): 
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The Tools Window includes shortcuts to 
frequently used repair, coloring and print 
preparation tools as well as Help text to aid 
with the repair work. You will later learn 
more about the use of the Tools Window.  

In the following we will use the Selection 
mode buttons to set the Selection Mode to 
correct level.  

You can use Shift + F8 to open and close 
the Tools Window. 

 

 

 

The selection is done with the left mouse button (LMB), and the selection target is 
controlled by the Selection mode buttons in the Tools Window:  

 

The four Selection mode buttons refer to (from left to right) selecting the whole 
model, one shell, one surface, one gap/triangle. Now try to select a shell from the 
display area, such as the ñ1. slubox-gap (Verified)ò. 

If the Selection mode is not Shell (which is the default) press  the  button  to 
turn on Shell selection. Then click on the model with LMB  and the shell will be 
selected. 

Then set the Selection Mode  to Surfaces  with  and click with L MB on 
surface 3  which now gets selected. If you wish to select objects behind surface 3 
just re-click with LMB (without moving the mouse. Instead of LMB, you can use the 
SPACE key, also without moving the mouse (this can help especially if mouse 
movement causes problems with a high-resolution display). 

Then press  the  button  to turn on the Gap selection and click close to the gap 
on the graphics area to have it selected in the Model Tree. 

Note : Triangle selection mode is available through the Color tab, and it is reserved for painting 
the model; please see ñTutorial 2 ï Working with Colorsò for more information. Otherwise, 
triangles are selected and manipulated through Fix Model > Edit Triangles command.  
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Multiple selection can be done by pressing the Ctrl key down while selecting 
objects from the graphical area or from the Model Tree with the LMB. The Shift key 
can be used to select objects between the first selection and the latest selection in 
the Model Tree. Different combinations Alt, Shift, Ctrl + LMB on the graphics area 
create, add and delete objects from the multi-selection, please see Online Help 
page Selection / Selecting objects. Multiple selection can be used with several 
commands, like Transformation or Fix Model menu commands.  

Display Area menu  

The right mouse button (RMB) has a special meaning on the display area.  

- Press the Surface  selection  mode  button  again. 

- Clicking the RMB on top of a displayed object now brings up the 
Display Area Menu (not available in Triangle/Gap selection mode): 

When you click the RMB on the model while 
in Surface selection mode the surface which 
is nearest to the cursor is indicated on the 
first menu item.  

- Click RMB on top of surface 3  
again . 

- With the Next/Previous  command 
you can indicate surfaces which are 
behind surface 3 along the line of 
sight at the mouse position.  

You can also change the shading and 
visibility of the selected object with the 
commands in the menu. If you wish to select 
the indicated surface, press Select . 

 

The 1487: OK triangle entry in the RMB menu indicates the input number of the 
triangle below the cursor. If this menu item is selected, more information about the 
triangle is displayed. This can be helpful especially when working with triangles 
with errors.  

The RMB menu of the graphics area is shorter in other modes than Surface 
selection and, for example, in Shell selection gives the name of the shell at the 
mouse location as the first item.  

A similar popup menu is available on the Model Tree with the RMB click, please 
try that too. 

Object properties  

Information about the properties of the currently selected object is given to the user 
in two different ways.  
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The basic information about the current selection 
is given below the Model Tree window. Much of 
the information is same as in the Object 
properties dialog (as explained below), but the 
information is structured in a different manner. 
There are also differences, like shell history 
which is shown more clearly in this list. 

 

There are three places to display the Selected 
Object Properties:  

¶ The menu command View > Object 
Properties or  

¶ the Model Tree RMB popup menu 
command Properties item  

¶ or the Display Area popup Menu 
Properties  

The Object Properties window contains a couple 
of items which are not available in the 
information below the Model Tree, for example 
the options to temporarily choose the objectôs 
display color, and at root level, change the unit 
of the model. 

 

The exact position of the part is given as bounding box values both in the 
information field and the Object Properties window. Also, the extents, volume and 
the surface area of the object are calculated.  

Note: with this example the Volume is not correct. This is because the model is not solid. The 
Volume is reliable with Repaired faceted models without gaps and for surface models with 
consistently oriented surface normal. The Area value is always valid both for surfaces and 
faceted models. 

 

Dimensions and Annotations  

For communication and documentation purposes it is often important to include 
dimensions and annotations to be stored with the model. The Dimensions menu 
gives us the tools to add dimension information to the model. 

 - Set Shell  Selection mode with the  shortcut button. 

Measuring and annotation tools can be started from the Dimensions menu or 
through the toolbar: 
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If the toolbar is not visible,  

- give command User Interface  > Toolbars > Dimensions Toolbar . 

Let's first take an absolute point value from the slubox-gap model.  

- Rotate and zoom the model  so that you can see it as shown here (you 
can also change the viewing and clipping during the dimensioning to get 
a good view of what you are measuring): 

 

 - Give command Dimensions > Point Value  (the  icon) .  

The Crosshair icon is shown on the display area and the program is waiting for you 
to select a point on the model for coordinate values. Select one point from the 
model and you will see a result like below (cropped): 

 

 

Let's now try distance between two points. This is done with 

- command Dimensions > Distance  or the  icon. 

After you give the command, you will see a new Crosshair icon. The number 1 
beside the crosshair icon tells you that it is waiting for the first point for the point 
distance evaluation. Now select the first point and the second point (crosshair with 
number 2 beside it) so that the result would look like the one on the previous image. 
Press RMB to accept or ESC to quit or cancel a selected point. 
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In the same way you can take Angle and Radius using the Dimension menu. Try 
to repeat the example shown on the next page. Keep in mind that you can Zoom, 
Pan and Move the eye point using the mouse and keyboard shortcuts. Dimensions 
> Wall Thickness allows to measure the wall thickness at a selected surface point.  

Pressing LMB only selects the closest surface point below the cursor for 
dimensioning. Pressing ALT + LMB causes the closest triangle corner point to be 
selected instead of the surface point below the crosshair icon. This will enable 
selecting accurate triangle corner points for the measurements: 

 

Now you are ready to edit and move the annotations (or measurements).  

- Click with the  right mouse  on top of an annotation . 

You should see the Annotations popup menu below. If you see the Display area 
RMB popup menu select the Next command in the popup menu until you get menu 
associated with the annotation: 
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This menu allows you to Edit, Move and Delete existing annotations. Try these 
commands on the selected annotation. The Edit operation only allows you to 
change the text contents: to re-measure the target points, you must make a new 
measurement (and possibly delete the original annotation). The Move operation 
similarly only moves the text box, not any of the measured points. 
You can also add free annotation texts and messages with Dimension > Mark-up 

command ( ). 
You can display model information on the screen by simply giving the command 

Dimensions > Object Info ( ).  
To copy the object info into the cut buffer, give command Dimensions > Copy 

Object info ( ). From the cut buffer it is easy to paste the information to Microsoft 
Excel, for example. 

Dimensioning can be made Sticky through the Preferences tab (see Edit > 
Preferences > General Tab), you can then give as many consecutive Point Value, 
Point Distance etc. commands as needed without the need to repeatedly restart 
the command. In the Sticky mode you should press ESC or RMB to quit when you 
are ready. You may try it now but remember to turn Off the Sticky mode before 
continuing.   

You can now delete all annotations by pressing the  icon. 

 

Repairing  the slubox model  

Now it is time to repair the gap in the slubox-gap model. 

Make sure the shell ñ1. slubox-gap (Verified)ò is selected in the Model Tree. Then 

- give the Fix Model > Repair Shells  command  and 

you will see the following parameter dialog:  
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- Just press OK when the parameter dialog appears, and you will have a 
correct slubox model in a second: 

 

 - Press OK to close  the Status message dialog.  

This was the first lesson covering viewing, dimensioning, popup menus, object 
selection and other basic software usability issues. In the sequel we will show the 
use of the actual repair and 3D model manipulation commands.  

 

 

Lesson 2 ï Fully Automatic STL fixing  

This lesson shows you how to fix an erroneous STL model for 3D Printing or 
simulation software use using the automatic tools with 3Data Expert software. 

Clean up the software workspace before continuing by  

- giving the File > New  command . Do not save the result of the previous 
example. 

 

Auto Repair process for STL files  

When inputting a triangulated model into 3Data Expert an automatic analysis and 
repair process is started. In normal everyday use you can correct most of the 
models using the Auto Repair process.  

- First open the dino -connected.stl file  in the Tutorials / GeomFiles 
directory. 

 You will be prompted for the units, accept the proposed unit, millimeters (mm): 
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 - Press OK  to continue and  

you will be prompted for the Operation Mode. To start fixing press the Fix button 
in the Operation Mode dialog now. 

3Data Expert will begin automatic model verification (the Fix Model > Verify Shells 
command). The screen is erased, and a progress bar appears. When the analysis 
is ready, the Auto Repair dialog with Model status message is displayed: 

 

The message indicates that there is one verified shell, which also contains errors. 
The display shows red Gap curves through the surfaces. Gaps are an error type 
you must fix during the repair process.  

- Press the Yes button  to initiate Auto Repair. The parameters are 
automatically set correctly.  

Auto Repair will attempt to fix all shells with errors. When you only have one shell 
in the Model Tree you should always try Auto Repair first.  

When Auto Repair is started the shell is run through the automatic repair command 
(Fix Model > Repair Shells command) using automatically calculated parameters. 
For each shell, a progress bar shows the progress of the repair. After the Auto 
Repair process finishes the following message is displayed for the dino-connected 
model:  



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

 Page 26 

 

- Press  the Close button in the upper right corner to close the window. Also 
close the possibly appearing tips and platform fit warning message.  

The model is now ready for output and 3D printing.  

 

During Auto Repair, 3Data Expert attempts to fill all gaps and remove non-manifold 
triangles (overlapping triangles, multi-edge triangles, duplicate triangles, triangles 
having less than three neighbors, etc.) from the model. Also, duplicate and 
overlapping surfaces are identified and optimally joined. To see more about 
triangle errors, please access the ñTriangle errorsò page in the Online Help chapter 
ñHandling Faceted Filesò. 

With certain models, you may see a different result icon for a shell in the Model 
Tree:  . This means that some errors have been found in the model, but they do 
not negatively affect the 3D Printing. The Help text below the Tools Window shows 
what errors remain in the model. What is considered a significant error, depends 
on the properties of the 3D Printing process. You can also change yourself the 
settings of what is an error and what is a warning, through Fix Model > Define 
Warnings: 

    

 

The dino-connected.stl model only has simple errors, like inverted triangles and 
gaps, which are all fully repaired during the Auto Repair process. You can now 
continue to save and print the model, as indicated by the status information in the 
Fix tab Help text window.  
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Lesson 3 ï STL fixing  

This lesson shows you how to fix slightly more erroneous STL model for 3D 
Printing or simulation software by using the automatic tools with 3Data Expert.  

Verifying and repairing the STL model  

Start this lesson by  

- File > New command to clean up the workspace. Do not save the result 
of previous example.  

- File > Open the STL model Tutorial s > GeomFiles > dino -
separate.stl . 

The software will prompt you for the Units and Operation mode as usual.  

- Accept m illimeters  (mm) units and 

- start the Fix mode . After a while the software displays the Auto Repair 
dialog with Model status message:  

 

 

This is the result of the automatic analysis (a separate verification of the input 
model with Fix Model > Verify Shells would yield the same result). We can see that 
the 9 shells in the Model Tree are all separated by thin gaps. 

The automatic verification and fixing functions in 3Data Expert have now analyzed 
the model and propose the following repair actions:  
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¶ Normal repair to stitch separate shells into one shell. This is done when 
more than 70% of the open edges between the different shells can be joined 

¶ Fill gaps in all shells is proposed as the model contains open/flat shells in 
the result which may require Offset or Extrude for proper fixing into a solid 
shell.  

¶ Remove tiny shells, less than 0.01 % of the total size, is proposed. This will 
ignore all insignificant shells smaller than the given size in the result. Minor 
shells can be the result of needle triangles and other minor errors in the 
model.  

We will now repair the model with complex gap errors into one single shell with the 
Auto Repair process.  

- Press Yes to run  the automatic repair on the model 

After a while we will have a fully repaired model in the Model Tree, ready for 3D 
Printing.  

 

 

Close the dialog  by pressing the Close button in the upper right corner of the 
message dialog. 

 

Verifying and repairing, take two  

In very old versions of DeskArtes 3Data Expert (10.0 and earlier) it was necessary 
to run the automatic repair for this model through Fix Model > Repair Shells 
command. In the following, the old way to fix dino-separate.stl file is repeated learn 
some basic concepts of model errors.  

Restart the lesson by 

- File > New  command 

- File > Open  the dino-separate.stl 

- Accept millimeters 

- start Auto Repair by pressing Fix in the Operation Mode window 
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You will again see the Auto Repair dialog with the status message. 

- press No  to quit Auto Repair process 

 

 

A status dialog appears:  

 

- When the status dialog is displayed, press OK  to close it. Close the Tip 
and does-not-fit-into-platform windows as well. 

The dino-separate.stl part is split into nine shells (components) which together will 
make the full part.  

 

Using Repair Shells command  

Thin gaps between the surfaces in a triangulation is normally caused by an 
erroneous surface triangulation for 3D Printing; The surfaces are triangulated 
separately without connecting the faces at the trim curves (or surface edges). 
Larger gaps may be due to missing surfaces in the original model. With DeskArtes 
3Data Expert you can easily repair these STL model errors: 
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In the Model Tree, after the Fix Model > Verify Shells command, the dino-separate 
model components are sorted according to surface area. This helps us to first 
delete unnecessary minor components from the model, by just checking the last 
small components in the Model Tree.  

- Select the last component 9. dino -separate (Verified)  and Fit it  on 
the screen: 

 

We can immediately see that this is an important component and must not be 
deleted. The components before the 9th are even bigger and must thus remain in 
the model. So, in this case we wonôt immediately delete anything. 

The next step is to combine the separate dino components into one connected 
part.  

- Use multiselection on the Model Tree  to select all components (or 
select Model Tree root): 

 

 

- Then start the Fix Model > Repair Shells  command  to stitch the 
components into one part and to fill in the missing soles of the dino. 

The command can be started from the Fix Model Tab shortcut button, too: 

 

Use the default parameters:  



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

 Page 31 

 

 

There are several parameters for the Repair Shells command. The parameters are 
automatically calculated for each model and can normally be accepted as is: 

¶ Normal vs. Simple repair: Normal will stitch separate shells into one shell, if 
possible. Simple repair repairs each shell separately and does not connect 
them into one.  

¶ Fill gaps in all shells vs. No fill for flat/open shells: 

 I Fill gaps in all shells fills all gaps in all shells, regardless of the shell 
shape, according to the Fill large gaps parameters.  

 I No fill for flat/open shells leaves flat shells unfilled. These shells may be 
more suitable to be filled with Offset or Extrude surface commands.  

¶ Check for triangle errors: to report intersections, multi-edge and overlap 
conditions 

¶ Consistency recheck: to check duplicate and overlapping surfaces and use 
optimal connection algorithms between these surfaces to form a solid shell.  

¶ Stitch gaps thinner than: to connect separate components where the 
distance between open edges is less than given value 

¶ Fill large gaps: to close all gaps smaller than given value. Value All is 
applied to close all soles of the dino. For textured and colored models you 
may want to apply Use surrounding texture and Use surrounding triangle 
vertex colors to keep the original colors in the result, otherwise the default 
foreground color is used for fill triangles (the foreground color is set in the 
Color  operating mode tab).   

¶ Remove tiny shells: shells whose area/volume is less than 0.01 % of the 
total area/volume are removed.  
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- Check that parameters are as in the image above and then press OK 
to start the Repair Shells command 

 

After a while the Repair Shells operation will finish and the status is displayed:  

 

The software reports a fully fixed model which can be printed with a 3D Printer. A 
close-up at the leg/body connection shows how the triangles are stitched at the 
gap area (displayed in shaded+wireframe mode): 

 

 

We have now fixed two models with relatively simple errors. For more information 
on how to fix more difficult STL and VRML models, please see the 3Data Expert 
16.0: STL and VRML repair examples document. The document covers the fixing 
of several difficult models for 3D printing and Additive Manufacturing.  
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Lesson 4 - Splitting and Combining STL  

This lesson shows you how to split large STL models for 3D printing and Additive 
Manufacturing. Building a very tall part may be more expensive than building two 
or more lower parts simultaneously. Also, the building area may not be large 
enough for a very big part. Correct joining of the split parts is ensured by adding 
guiding pins to the models.  

This lesson is not applicable to 3Data Expert Free.  

Splitting the dino model  

- Start by inputting the DeskArtes geometry file DinoOk.3de  In the 
Tutorials / GeomFiles directory.  

- Set the file type to .3de to input DeskArtes proprietary files: 

 

The DinoOK.3de file includes a correct triangulation for the familiar dino model.  

You should accept the proposed units and go directly to the Modify  mode  by 
pressing the 

 

button in the Operation Mode Window. You should see the following dino model:  
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with the Modify Tab on the right-hand side of the screen. 

 

The Modify Tab gives shortcuts to the 
commands most used for adding or 
changing geometry before the final print 
preparation, like split, connect, add lap 
joint, hollow, offset, drain hole, 3D text. 
The Help text provides context sensitive 
help to the commands. 

 

 

- Select node 1. DinoOk (Repaired)  by clicking it with the left mouse in 
the Model Tree. 

Before splitting we must take a correct view to the model because the splitting 
plane is generated by extruding a user drawn split polygon away from the viewer. 
With 3D Printing the correct way normally is to split the model perpendicular to the 
z-axis to make the part lower. Thus,  

- take a view from the x -axis direction with View > Ortho View > Front 

(+X) (  + LMB). 
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The splitting is  

- started now with command Modify Faceted  > Split  or with icon 

 

The system prompts you to take the correct view (in case you havenôt set  it yet):  

 

When the view is correct you can  

- press Continue  or Cancel to quit. You may hide this window 
permanently when not needed anymore. 

The system asks you if you wish to use a Polyline (linear), Curved split line or exact 
Coordinate value.  

- Select Polyline  

 

- press OK  and the system goes into the curve edit mode where you can 
define the shape of the splitting surface. 

 

Now you can draw the shape for the splitting surface.  

- Draw a horizontal line by giving two points with the LMB clearly 
outside of the dino  model  

as seen here (the line is exactly horizontal when a dashed help line extends as a 
continuation of the line):  
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The curve editing is finished by  

- pressing the RMB (or ESC key to cancel if you need to redraw) 

When finished the model is split along the plane defined with the user drawn 
polyline, Select the second shell in the Model Tree to highlight the top half: 

 

 

The two halves are grouped and named with a- and b- prefixes to distinguish 
between the shells above the split line and below the split line.  

Note : If you are splitting models with more than one shell you can select the a or b part with 
the Groups command in the Model Tree popup menu.  

 

Creating the pins  

The separate parts of the model could now be stored into .stl files for 3D Printing. 
However, precise joining of the ready parts would be difficult or impossible. To be 
able to position the parts accurately after the build, we shall add pins and holes in 
the shells to connect them together when they come ready from 3D Printing. 

We will first select and show the locations of the primitives required for connecting 
the two parts together. For that we will get a nice view for pointing the pins on the 
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screen. Here we are also using the shaded+wireframe view mode through the   
icon in the Viewing Toolbar.  

- Rotate the model to position shown in the image below 

- erase the screen with  and 

- select the lower part of the dino  and Fit it  on the screen , so that 
it is displayed properly on the screen 

- set on shaded+wireframe mode with  the    icon  

Zoom close to the model to be able to accurately position the pins: 

 

The pins are now  

- added with the Modify Faceted  > Connect  command or 

using the Modify Tab shortcut 

 

After the command is given, it is possible to give the shape and the size for the 
pins to be created. Set Diameter and Length both to 10.0, as seen below:  
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The positions for the pins should look like the this:  

 

If a pin is incorrectly located on the shell, you can remove it by clicking the red 
indicator cone again with the LMB. Then reposition the pin again with an LMB click. 

When ready  

- press OK to generate the connectors.  

After a while you will see the connectors added to the selected shell (in shaded 

mode again with the  icon in the Viewing Toolbar):  

 

Corresponding holes are automatically created into the b-dino-Ok shell. You 
should move the shells apart from each other with the Transform menu commands 
prior to outputting the model for 3D Printing.  

For a robust Boolean operation between the selected surface and the pins, the 
connector is positioned on the surface so that 10% of the height is below the 
pointed surface. 90% of the pin length is above the surface and will be cut into the 
opposite part.  
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Saving the result  

You can save both files into the same STL file by selecting the Model Tree root All. 
Anyhow, you normally want to build and position the parts separately in the 3D 
Printer. For that select each shell separately and  

- output  it to a proper STL file with File > Save As  command . 

If you wish to save the two parts into one file, you should move the shells apart 
from each other with the Transform or Print Preparation > Move Platform menu 
commands prior to outputting the model for 3D Printing. To output one file, select 
the Model Tree root All before the Save As command.  
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Using Lap Joint to connect thin parts  

With this example we will split a part with thin walls and connect it with a lap joint 
connection. A lap joint is a small overlapping structure on both sides of the wall 
along the split surface edge. With Lap Joint command you can generate strong 
bond even along very thin walls.  

We will first input the familiar slubox-gap.stl file and repair it for Splitting: 

1. Input file slubox-gap.stl file with File > Open.  

2. Accept millimeters as the unit. 

3. Choose  Fix in Operation Mode to go to the Auto Repair process. 

4. When asked ñDo you want to run Auto Repairò press Yes.  

5. And after a while you will get ñCongratulations, the model is correct 
and can be saved and printedò message.  

6. Press Close button in the upper right corner to close the status 
message window. Also close other possibly appearing messages. 

You now should have the slubox model fully repaired for splitting: 

 

- Take a suitable view direction +Y for splitting  by pressing the  icon:  
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Start model splitting with  

- Modify Faceted  > Split command now and 

- select Split curve type  Curved line , as seen in the next page.  

This time we want to make a split line which is not straight, i.e. it has teeth, and the 
split line corners are slightly rounded. This will allow us to create a connection with 
no freedom of movement between the split parts as well as to avoid small holes 
between the connected halves due to too sharp corners in the split plane.  

 

- Press OK to start adding curve points. 

For each split curve point at the curve corners below  

- press twice  for each point with the left mouse  (points inside the red 
ellipse below). 

This will generate a rounding with small radius at each corner (single click would 
generate a ñwavyò split line): 

 

Or if even a bigger radius is needed at each corner, create two points close to each 
other, not double points3. This will increase the radius at each corner and allow to 
use bigger Lap Joint Height values later, for example.  

When ready drawing the split line,  

- press RMB to split the model: 

 
3 The curve is actually a Bézier curve. 
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If you now display the selected half of the model and zoom closer to the tooth, you 
can see that there is a small rounding to enable more accurate building of the part 
without cracks at the sharp corners: 

 

 

Adding Lap Joint  

You are now ready to start generating the Lap Joint.  

- Give the Modify Faceted  > Lap Joint  command.  

You can also start it by pressing the Lap Joint icon in the Tools Window Modify 
tab:  

 

Let's now fill in the parameters for the Lap Joint command. It is important to use 
parameters suitable for the split part. The Lap Joint Depth (2 mm) must not be too 
deep when compared to the wall thickness (about half) and Height (2 mm) should 



3Data Expert 16.0: Tutorial 1 - Working with 3D Models  

 Page 43 

be suitable to create a strong bond between the two halves after the build. There 
are also three different Lap Joint Types available, this time we will  

- use Thin wall type  to create the lap joint structure just on one side of 
the part. 

- Fill in the parameters seen below:  

 

The Allowance 0.1 mm will leave a small void between the lap joint halves for the 
parts to fit easily and to allow for adding adhesive between the lap joint halves.  

You are now ready to select the Lap Joint locations. Locations must be selected 
along the split surface edge. When a lap joint location is selected, a red indicator 
box appears on the edge (see picture below) and the lap joint area is shown with 
yellow indicator boxes. The yellow indicator boxes allow you to check that the lap 
joint is correctly located as well as that the Depth and Height are reasonable. Also, 
if the yellow boxes intersect each other, the generated lap join may not be valid. 
To redefine a lap joint, click the red indicator box and the lap joint disappears. 
Modify the parameters or press another point to change the location, if necessary.  

You can use mouse wheel zoom and middle mouse rotation during the Lap Joint 
command to visually check the lap joint area.  

As in the picture below  

- select two locations  indicated with red boxes. 

The yellow boxes show the size and location of the corresponding lap joint 
structures: 
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When ready defining the lap joints,  

- press OK to create them . 

The lap joint structure is automatically deleted from the displayed part and added 
to the other split halve (thus you must not move the split parts before adding lap 
joints between them).  

Note also, that the lap joint positions (red boxes) are selected at the edges of well 
behaving triangles (not thin), this will ensure the best possible result with the lap 
joint generation.  

After pressing OK, the software checks if more than one lap joints should be 
generated.  

- Press Yes to generate both areas. 

 

 

After a while you will see the result, a lap joint structure deleted from the other part 
and added to the other halve: 
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The parts can now be outputted and built separately and then accurately joined 
and glued back together.  
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Lesson 5 ï Positioning Parts  

This lesson shows you how to use the 3Data Expert commands to position parts 
before transferring to Additive Manufacturing machines. The Platform definition 
and Move to Platform commands are accessed through the Print Preparation 
menu.  

This lesson is not applicable to 3Data Expert Free, where part positioning must be 
done manually.  

Note : Most 3D Printing systems will reposition the part when inputted into the 3D Printer control 
software.  

Print Configuration  

When you start 3Data Expert, you will see a workspace4: 

 

When 3Data Expert is started the first time, a default Print Configuration 
(GenericDLP) is loaded, along with an associated workspace. We will now show 
how to load another configuration set saved during the 3Data Expert installation. 
Note: this lesson is only meant to be a guideline, you may have a suitable Print 
configuration pre-installed and loaded. 

First, letôs make the Tools Window visible via User Interface > Tools Window (or 
Shift + F8).  

 

 

4 If the workspace is not shown, click the  button to make it visible 
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Then choose the Print  tab. The Print Configuration file 
interface is displayed as its first group. 

Below the Print configuration group, the most often used 
parameters (which are often modified during print 
preparation) are shown. 

From the File drop-down list, you can choose a 
configuration from the preset configurations (or a 
previously used one): 

 

Click the  button  now to get a closer look at how to 
choose and tune different Print Configurations. 

 

The Generic DLP parameters are shown in the Print 
Configuration and shown in the dialog. You will see 
the Print Configuration Setup interface (picture on 
the right). On top, there is the Print configuration 
settings file management area. Below it, you can 
see the parameter categories and category-specific 
parameter values. 

From the settings file management area, you can: 

¶ Load settings from a parameter file (for 
example, to open a Print Configuration tuned 
to better match your 3D printing 
requirements). 

¶ Save current settings into a parameter file. 

¶ Change the order in which Print 
Configurations appear in the drop-down 
menu (useful if you have many of them). 

¶ Select where to browse the parameter files, 
either system or personal folders 

¶ Import and export support parameter files (a 
subset of the setup) for use outside the Print 
Configuration context. 

 

The parameters themselves are divided into several categories. For simplicity, letôs 
only look at the workspace size. Click the ñWorkspaceò category. The type and 
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size of the workspace are displayed, as well as additional parameters required for 
a specific printer. Change the workspace box dimensions: Xmax to 200.0 and Zmax 
to 300.0: 

 

Then click OK  to close the Print configuration parameter edit window and start 
using the new parameter set.   

Letôs now try to exit from 3Data Expert. A warning is shown that the print 
configuration has been changed. Click No  in the message window, because we 
want to save our modified Generic DLP parameter set for later use. 

 

Now, re-open  the Print configuration setup  window with the  button, click 
Save to select where and with which name to save the parameter set: 
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In the file dialog, go to the folder where you want to save the print configuration 
setup, type the new parameter file name, and finally click Save. 

Now you can quit 3Data Expert. The next time you start it, the print configuration 
parameters last used are automatically loaded: 

  

 

Moving parts in to  the platform  

Now we will see how the Print Preparation > Move to platform commands are used 
for positioning the part into the workspace. The move platform commands will now 
use the minimum/maximum x,y,z values of this platform when computing the 
default values for the movement. 

Let's first  

- input the model Tutorials/GeomFiles / rava2.stl using the File > 
Open command  

- simply close the Operation Mode window by pressing its close 
button .  
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We can see that the part is not fully inside the build area, both visually and from 
the model properties window at bottom left (platform size, bounding box, extents).  

- Select part rava2  from the Model Tree , then 

- move the part into the area with the command Print Preparation > 
Move to Platform > Move positive .  

The command suggests the default values which are the same as the minimum 
bounding box values for the workspace.  

- Fill in the values below and press OK. 

 

 
This means that the minimum corner point of the part bounding box is set to the 

given values. You can check this by turning the grid on  and taking a view from 
the +X direction:  

 

 

Then give  command  Print Preparation >  Move to Platform > Move center  (or 

click the  button in the Position tab). 

Move Center computes the center point of the selected platform and uses this as 
the default for x and y values. The xy center point of the object is moved to this 
point. You still must give the z distance from the bottom of the vat (to allow for 
supports, for example).  

- Fill in the level value below and press OK. 
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You should get the result as view here from X axis (left) and Z axis (right). Note 
that the model barely fits into the workspace and would require either splitting or 
scaling: 

 

 

The Move to Platform > Move Level command only moves the part in z-axis 
direction to add sufficient space for supports.  

You may want to try the normal transformation commands also. They are 
accessible from either the Transform menu, the Transform toolbar or the Position 
tab: 
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The toolbar includes commands for part moving, scaling, rotation, and mirroring. 
The Transform menu gives you more commands, like numeric transformations, 
scale from MM to Inch and the other way around. The Position tab contains the 
most used transformation commands and additional tools from other menus: 
Duplicate object, Merge shells, and Copy to array, Move to platform center, Move 
to platform level. 

 

Lesson 6 ï Nesting  

This lesson shows you how to use the 3Data Expert commands to position parts 
automatically using 3D Nesting.  This is done with Print Preparation > Nesting 
Tools > Nesting command. Currently 3D Nesting is available for efficient part 
merging for powder-based system which do not require supports during the 
manufacturing.  

This lesson is only applicable with the Base and Lite modules   . 

 

3D Nesting regular components  

In this example we will pack a set of consistently ordered similar components into 
the work area, aka bin with nesting. The goal is to organize 73 scaled rava2 parts 
into the bin as effectively as possible.  

In the images below we have 73 original components show in the left-hand image 
and nested 73 components in the right-hand image: 

  

 

Before nesting we need to generate the 73 components to nest: 

- Input rava2.stl  and run Fix Model  process on it 

- Use Transform > Scale > Numeric  to scale it to 20% of the original size 
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- Create an array  of objects with Edit > Copy to Array  command or, in the 

Position tab, click the  button 

 

- Click OK. After a while you will see an array of 72 components added to the 
Model Tree 

 

The 72 new copies are in a single shell. For Nesting we must separate each copy 
into its own shell. 

- Select the ñ2. Rava2 (Copy Array )ò shell and run Fix Model > Verify 
Shells  command on all components to separate the copies 
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- After a while you will have the original and 72 separate new shells in the 
Model Tree 

 

 

We are now ready to start nesting the parts. You may want to read the Help pages 
for the Nesting command to generally learn about the different parameters 
available for the Nesting command. In the sequel we will make some specific 
changes to the default parameter set to get the best possible nesting result for the 
rava2 array.  

We will start the nesting by 

- Select the Model Tree root All  

- Give the Print Preparation > Nesting Tools > Nesting  command and you 
will see the Nesting parameters dialog.  

Fill in the parameters below, if not already set. Especially note the Orient algorithm 
= orig-dir and Init algorigihm = bin split. The component directions will not be 
changed during the nesting and the bin initialization is done by splitting the bin into 
boxes which fit each component. A one-minute run time is sufficient because most 
of the nesting is performed by the initialization algorithm (bin split).  
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- Press OK to start the nesting 

- About one minute later you will have the result in the Model Tree: 

 

Generally, it is useful to position the components so that the longest edge is along 
the longest edge of the bin. If the Orient algorithm is set to z-rot or xyz-rot, the 
software will try to find the longest component edge and align it to the longest bin 
edge before the initial bin fill.  

3D Nesting irregular components  

When the components are more irregular and/or different sizes, different 
initialization and orientation algorithms can be used to achieve better results than 
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simple z-rot/bin split algorithms would give. We will give a couple of examples here 
and also show how the allowed nesting time affects the results.  

We will first prepare a set of dino components to nest: 

- Input dino -separate.stl  and run it through the Fix Model process  

- Change the workspace size to 250 * 250 * 250 cube ( Print Preparation 
> Print Configuration > Workspace ) 

- Scale the model to 50%  of its original size 

- Create Array of 49  components 

 

- Run Verify Shells  to separate the Copy Array result to shells 

Now you should have a set of 50 dino shells in the Model Tree. For easier 
comparison during later steps, take a view from the X axis, fit the workspace into 
the view, with some extra space above:  

 

Next, we will run the shells through the same parameters as was done with the 
rava2 example above. We will use a bit longer run time, 1 min 30 sek. 

- Select  Model Tree root All  

- Give command Nesting  with the following parameters (orig-dir, bin-split):  
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- Press OK  to start nesting 

- After a while the result is available in the Model Tree: 

  

This time the shells did not quite fit into the workspace. Anyhow, with more dense 
merging the shells should fit there.  

Letôs try improving this nesting with the z-rot and rain-fall methods: 

- Start the Nesting  command again with the following changed parameters: 
Orient alogrithm = z-rot and Init algorithm = rain fall. 
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- Answer Yes to the question asked after the OK is pressed. This will 
continue with the existing nesting and improve it using the nesting algorithm: 

 

This time the nesting should be lower or even fit into the bin. In the image below is 
one example of the new nesting result:  

 

After a couple of improvement runs, we will get a more compact nesting:  
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You can still try another Orient algorithm, xyz-rot (marked with red line below), 
where the shells can be rotated freely during the nesting.  

 

The result will be similar in height than the previous exaple, and can be improved 
by rerunning the command on the result.  

 

After a couple of iterations, some of them using z-rot, some xyz-rotz, we may 
achieve a result like this: 

 

 

Above we were using 1 min 30 sec run time. With some model compositions using 
a longer run time, like 30 minutes, yields the best result. However, a better packing 
can be often be achieved using shorter run times and alternating between z-rot 
and xyz-rot parameter settings. 
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Lesson 7 ï Adding 3D Text  

 

Sometimes it is necessary to add decorative texts or tag parts with individual texts 
to tell them apart after the build. The 3D Text and Boolean commands make 
marking parts easy and effective.  

This lesson applies to Base, Lite and Color modules only.  

Creating 3D Text  

Normally you want to add the 3D text on a part to be built. To start the lesson, first 
input and repair slubox-gap.stl: we will first input the STL file and repair it for adding 
text: 

1. Input file slubox -gap.stl  file with File > Open. 

2. Accept millimeters as units. 

3. Press Fix Model  with Operations Toolbar to go to the Auto Repair  
process. 

4. When asked ñDo you want to run Auto Repairò press Yes . 

5. And after a while you will get ñCongratulations, the model is correct 
and can be saved and printedò message.  

6. Press Close button  to close the status message, as well as all other 
similar message windows.  

You should now have the slubox model fully repaired for adding 3D text. Take a  

- view from Y axis direction and  

- give the command Create Geometry > Create 3D Text :  
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Fill in the values given in the dialog above: Size 12 mm (vertical height), Height 1.2 
mm (=text height from the surface) and finally String ñslubox repairedò. The font is 
preset to Arial, well use that. Show position on surface is set. When we  

- select Surface operation  Engraving . 

- make sure Show position on surface  is set . 

- press OK  the program asks us to show a line on the surface along which 
the text will be generated. 

- You can now position the text with LMB  on the correct location. 

When positioning the text just make sure the whole text fits on the flat surface area 
on slubox:  

 

If necessary, you can scale and rotate the text on the graphics area to better fit it 
on the slubox model. The yellow Help text window on top of the graphics area 
shows the different text positioning options available: 

 

When positioning is done, click RMB to start text engraving. 

Soon you will see the text engraved on the slubox surface (turn wireframe off and 
rotate the view to better see the text): 
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Generally, 3D Text can be attached on both flat and curved surfaces. If the surface 
is curved, you should use the Curved surface option to reliably attach the text on 
the surface. If not used and the surface is too curved along the given text path, 
some letters may not be attached to the part or may be fully inside the part.  

 

Adding 3D Text to multiple parts  

Sometimes it is necessary to add text and label strings to multiple objects at once. 
For example, quality checking may require that every object on the printing 
platform can be uniquely identified.  

An indexed Label string can be added to the shell onto which the 3D text is added 
(engraved or embossed); this will help component identification, together with the 
Production Screenshot image or the Generate Report documentation.  

Note: The parts which will be added with the same text must be rather similar. The 
text position is defined in relation to the bounding box middle point of each 
component. If the shape of the components is very different, the text in each shell 
may end up in wrong locations.  

For this example, we are using the 12-cellphones.3de file in the GeomFiles 
directory.  

- Input the 12-cellphones.3de  file (closing the Operation Mode dialog with 
the upper right corner X) 

 

- Take a view from the Z direction 

- Zoom into one of the copeis to define it as a reference shell: 
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The goal is to add an identifying string to each of the components for identification 
after the build. This is achieved with the 3D Text dialog fields Set Production 
Screenshot Label string, Apply text to all multi-selected objects and Add indexing 
to the string. 

- Keep Model Tree root All  selected  

- Give  the command Create Geometry > Create 3D Text  

- The Text Input  dialog appears. Make sure all the values are as seen in the 
image next page: Letter size, Height, Show Positioné, Set Production é, 
Engraving, Add indexé, Apply text toé etc. The shell is rather thin, so 
especially the Height/depth must be very small.  

 

- Press OK to start positioning the text on the reference shell currently in view 

- Position the text on top of the reference shell. Move  the text with LMB, 
rotate  with Ctrl+LMB , resize with Shift+LMB : 
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When the text is at the correct location on reference to the upper left shell,  

- Press RMB to add the text to all selected shells 

- After a while the result is visible at the Model Tree, each component has the 
text with increasing index added: 

 

 

The Text is added starting from the last selected shell in the Model Tree before the 
command was given and continues towards the shells higher in the Model Tree. 
Before the command the highlighted shell was the last in the Model Tree and will 
get the text ñcmp00ò: 

 

 

After the command the last shell is the first in the Model Tree with the ñcmp00ò text: 
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The Label string can be seen in the properties area below the Model Tree or with 
the Object Properties command:  

 

 

- Save the resulting  model  as  12-cellphones -3D-text.3de  for the later 
lesson on Production Screenshot command.  

 

Adding 3D Text on curved surfaces  

3D text can be added on curved surfaces too. However, you need to take care with 
the parameters to ensure that the 3D text is visible on all desired locations.  

Letôs create a primitive cylinder with 20 mm height and 10 mm radius for this 
lesson.  

- File > Close  the current model to get an empty model 

- Create a cylinder  with Create Geometry > Cylinder  command 
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- Press OK to save the cylinder; you should automatically get a clean cylinder 
without the need to repair it: 

 

 

We will now add simple text on top of the curved cylinder vertical side.  

- Start  the Create 3D Text  command and fill in the following parameters, 
especially note the 400% Tool depth. This will use up to 8 mm (4*2mm) high 
letter primitives to cut the text on the curved surface. Feel free to use the 
font and text of your preference.  
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- Press OK to show the location on the model 

 

- Scale the text  (Shift+LMB) to fit on the surface as shown in the above 
picture. 

- You can see a quick glimpse of the temporary engraving tool surfaces (used 
for the Boolean operation) before the actual result appears:  

 

- And finally, the correct engraving: 

 

The text is correctly cut against the model. Letôs try the operation with a smaller 
engraving tool height.  

- Undo  the last command 

- Give  Create 3D Text  with 100% tool height (try an even smaller percentage 
if the result is still correct after the Boolean operation) 
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- Press OK to add the text 

- The end result is a model where the text is not properly attached to the 
cylider model, as can be seen in here (left: shaded, middle: wireframe 
zoomed, right: wireframe looked from almost Z axis):  

 

So, it is important to use a big enough tool height with highly curved surfaces. Also, 
to get the most accurate text projection on the surface, the viewing should be as 
directly towards the average normal of the text insert surface, or anomalies may 
appear.  

 

Lesson 8 ï Generating AM reporting  

This lesson shows you how generate different reports for AM production and 
quality control.  

 

Production Screenshot command  

The Manufacturing menu in 3Data Expert 16.0 is intended to contain commands 
which are closer to the ready built AM part. Currently it includes commands to 
produce documentation for post-processing operations and quality control.  

The Production Screenshot command is meant for generating documentation to 
help identifying the parts on the platform after the build. First the user sets up the 
suitable part positioning and orientation on the build area for the parts and 
supports. When ready to go for slicing it is time to produce the Production 
Screenshot. Here we are using as an example the result from the previous 
example, 12-cellphones-3d-text.3de file.  

- Input the 12 -cellp hones-3d-text.3de  

- Skip the Auto Repair process (simply close the Operation Mode dialog) 

- Give the command Manufacturing > Production Screenshot .  

 

You will soon see a view from the positive Z axis with additional yellow info boxes 
for each component on the platform.  
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Each info box is connected to the corresponding component with a red line (close 
to the middle of each component). In this case the Label strings created with the 
3D Text command are visible in both the info boxes and as engraved into the 
components. This will make identification of each component very easy after the 
build. The properties (size) of the building platform are also shown on the upper 
left corner of the platform; if the platform is defined but not visible, tick the Include 
building platform check box. 

To minimize info box cluttering you can rearrange them with LMB. The info box 
target points can be re-positioned similarly. 

The Export as image button allows saving the image (as a 
PNG file) with a desired name on the hard disk. The 
exported .png file can be inputted or copy/pasted to 
different Microsoft Office documents (for example) for part 
identification and commenting after the build. 

Clicking OK will store the screenshot into the model for 
later viewing with Manufacturing > Show Production 
Screenshot (when the model is saved in either .3de or 
.3dez format). 

 

Generate Report command  

The Generate Report command in Manufacturing menu will allow automatic 
transfer model and geometry related info into MS Office documents for quality 
control purposes. The transferred data will include model name, volume, surface 






































































